Электронная коммерция с WordPress, как создать интернет-магазин?

Первый тематический митап про WooCommerce (и не только) состоится в Москве 20 сентября. Обсуждаем особенности создания интернет-магазинов на WordPress, плагины, темы, оптимизацию работы сайта.

Приглашаем всех, кто интересуется электронной коммерцией, имеет опыт или планирует открыть свой интернет-магазин.

Подробности по ссылке

Конференция WordCamp Москва 2018

В этом году WordCamp Moscow впервые будет длиться два дня! Мероприятие пройдет 18 и 19 августа в центре Digital October!

Посетите сайт конференции, чтобы ознакомиться с подробностями, стать спикером, спонсором или зарегистрироваться для участия в конференции!

Конференция WordCamp Санкт-Петербург 2018

Конференция состоится 26 мая 2018 при поддержке компании SEMrush.
Хотите поучаствовать, поделиться сообществом своим опытом или просто рассказать что-то интересное из мира WordPress?
Приходите, будет интересно!
Полезные знакомства, новые доклады, футболка с символикой WordPress, пицца и after-party.
Подробности на сайте конференции.

Готовы ли вы к WordPress 3.2?

WordPress 3.2 выйдет совсем скоро, и мы хотим, чтобы вы были готовы! Обратите внимание: в новой версии изменились минимальные требования.

PHP и MySQL

Версия 3.2 требует PHP 5.2.4 и MySQL 5.0. Согласно нашему прошлогоднему исследованию, процент пользователей со старыми версиями PHP и MySQL относительно мал. Но когда речь идёт о более чем 45 миллионах пользователей, даже небольшой процент может означать огромное число людей. Не дайте застать себя врасплох — перед обновлением убедитесь, что на вашем сервере установлены подходящие версии PHP и MySQL.

Войдите в панель управления хостингом и убедитесь, что там доступны PHP 5.2.4 или выше и MySQL 5.0 или выше. Большинство хостинг-провайдеров уже предлагают эти или более свежие версии по умолчанию, но есть и исключения. Если у вас используется старая версия, в панели должна быть возможность переключиться на новую.

Если вы не знаете, как найти в панели управления хостингом эту информацию или даже как туда попасть, не переживайте. Узнать, готовы ли вы к версии 3.2, можно с помощью плагина Health Check. Перейдите на страницу «Плагины» → «Добавить новый» и сделайте поиск по словам «health check» — плагин должен появиться в первой строке. Установите его, активируйте, и он покажет, есть ли необходимость в обновлении.

Если вам всё равно нужна помощь, напишите в службу поддержки хостинг-провайдера письмо с подобной просьбой:

Добрый день. На вашем хостинге расположен мой сайт [site.ru], который работает под управлением системы WordPress. Её минимальные требования повысились до PHP 5.2.4 и MySQL 5.0, и я хочу узнать, соответствует ли мой сайт этим требованиям. Если сейчас у меня используется старая версия PHP или MySQL, можете ли вы обновить её или рассказать мне, как это сделать? Большое спасибо!

Если ваш хостинг-провайдер ответит, что такой возможности нет, — вероятно, пришло время выбрать другой хостинг.

IE6 и устаревшие браузеры

В версии 3.2 мы также отказались от поддержки Internet Explorer 6, устаревшего 10-летнего браузера, который даже сама Microsoft уже готова забыть. Если вы откроете консоль через устаревший браузер, мы сообщим вам об этом. Почему это важно? Потому что веб-технологии развиваются, а с ними и WordPress, ведь его функции опираются на новые возможности. Если вы используете устаревший браузер, то впечатление от работы с WordPress будет неполным.

Если ваш браузер устарел, вы увидите в консоли симпатичный оранжевый блок с сообщением о новой версии (который, конечно, можно убрать). Но если вы используете IE6, то блок будет красного цвета, а сама панель управления не будет корректно работать. Если вы застряли на IE6, потому что компьютер принадлежит компании, библиотеке, школе и т.п., и вы не можете обновить браузер, попробуйте написать письмо вашему системному администратору:

Добрый день. На компьютере, за которым я работаю в [местонахождение компьютера], установлен устаревший браузер. Internet Explorer 6 был создан 10 лет назад, до появления современных веб-стандартов, и он не поддерживает современные веб-приложения. Всё больше сайтов и приложений отказываются от поддержки IE6, и среди них новая версия WordPress. Даже компания Microsoft, создавшая IE6, считает дни до его исчезновения (см. http://www.ie6countdown.com/). Можете ли вы установить на имеющиеся компьютеры свежую версию IE или какой-нибудь другой современный браузер (см. http://browsehappy.com)? Большое спасибо.

Добро пожаловать в будущее!