Этот плагин не тестировался с последними 3 основными выпусками WordPress. Скорее всего, он уже не поддерживается и может быть несовместим с текущими версиями WordPress.

Google Syntax Highlighter for WordPress

Описание

This plugin easily integrates the Google Syntax Highlighter by Alex Gorbatchev into WordPress.

Feature summary

  • 100% client side, no server dependency
  • Multiple languages support
  • Wide browser support
  • Very lightweight

Languages Supported

  • C++ (cpp, c, c++)
  • C# (c#, c-sharp, csharp)
  • CSS (css)
  • Delphi (delphi, pascal)
  • Java (java)
  • Java Script (js, jscript, javascript)
  • PHP (php)
  • Python (py, python)
  • Ruby (rb, ruby, rails, ror)
  • Sql (sql)
  • VB (vb, vb.net)
  • XML/HTML (xml, html, xhtml, xslt)

Скриншоты

  • Simple Ruby Example

Установка

  1. Extract plugin into /wp-content/plugins directory.
  2. Activate the plugin.
  3. Specify your code snippets in your blog post using the Usage Directions provided by the Google Syntax highlighter.

Here is an example to produce ruby syntax highlighting once the plugin is activated:

<pre name="code" class"ruby">
def my_ruby_snippet
  blog_post.should(be_highlighted)
end
</pre>

Участники и разработчики

«Google Syntax Highlighter for WordPress» — проект с открытым исходным кодом. В развитие плагина внесли свой вклад следующие участники:

Участники

Перевести «Google Syntax Highlighter for WordPress» на ваш язык.

Заинтересованы в разработке?

Посмотрите код, проверьте SVN репозиторий, или подпишитесь на журнал разработки по RSS.