Этот плагин не тестировался с последними 3 основными выпусками WordPress. Скорее всего, он уже не поддерживается и может быть несовместим с текущими версиями WordPress.

Instant Cookie Expire

Описание

Limiting the cookie expire time of password protected posts. By default the cookie set when entering a password to access a password-protected post will be active for 10 days. This plugin turns this cookie into a session-based cookie. This means your visitor will need to re-enter the password if the browser was closed prior to revisiting the post.

Установка

By following these instruction, you’ll be able to install Instant Cookie Expire.

e.g.

  1. Upload the plugin files to the /wp-content/plugins/instant-cookie-expire directory, or install the plugin through the WordPress plugins screen directly.
  2. Activate the plugin through the ‘Plugins’ screen in WordPress.

Часто задаваемые вопросы

I closed the browsertab and opened a new one, but your plugin does not work?

This is expected behaviour. Since the cookie works session-based, a password won’t be requested again unless the user closes the browser entirely.

Отзывы

06.06.2017
Attempted to use this with my protected pages. Made sure that I emptied my cookies first so that I knew I'd have to enter the password. Entered PW, fully closed broswer, came back in and had no issue openeing the pages. Uninstalled and off to find another solution.
Посмотреть 1 отзыв

Участники и разработчики

«Instant Cookie Expire» — проект с открытым исходным кодом. В развитие плагина внесли свой вклад следующие участники:

Участники

Перевести «Instant Cookie Expire» на ваш язык.

Заинтересованы в разработке?

Посмотрите код, проверьте SVN репозиторий, или подпишитесь на журнал разработки по RSS.

Журнал изменений

1.0.1

  • Altered the plugin code. Thanks to the suggestions of pjherrel.
  • Updated the description for WordPress 4.6

1.0

  • First release.