LH Agree to Terms

Описание

I wrote this plugin as I needed full flexibility when adding an «agree to terms» check box to your login or registration forms,

Not only does this plugin facilitate requiring users to agree, but also allows you to customise and configure the terms and conditions message, add links, and also the customise the message those who have not agreed see.

Additional features include:

  • User registration support
  • Buddypress support
  • Multisite support

Установка

  1. Upload the entire lh-agree-to-terms folder to the /wp-content/plugins/ directory.
  2. Activate the plugin through the ‘Plugins’ menu in WordPress.
  3. Go to Settings->Agree to Terms to enable for login and/or registrations, once enabled you can set details like label and error message.

Часто задаваемые вопросы

Installation Instructions
  1. Upload the entire lh-agree-to-terms folder to the /wp-content/plugins/ directory.
  2. Activate the plugin through the ‘Plugins’ menu in WordPress.
  3. Go to Settings->Agree to Terms to enable for login and/or registrations, once enabled you can set details like label and error message.

Участники и разработчики

«LH Agree to Terms» — проект с открытым исходным кодом. В развитие плагина внесли свой вклад следующие участники:

Участники

Перевести «LH Agree to Terms» на ваш язык.

Заинтересованы в разработке?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Журнал изменений

1.00 April 25, 2016
Initial release.

1.10 May 06, 2016
Backend fix.

1.11 May 24, 2016
Minor fix

1.12 June 06, 2016
Better translation support

1.13 June 22, 2016
Added Settings Link and buddypress support

1.14 November 05, 2016
Fixed so it works with xmlrpc

1.15 January 30, 2017
Play nice with rest api

1.16 March 30, 2017
Move option settinsg into partials file

1.17 July 29, 2017
Added remember terms option

1.19 August 01, 2017
Removed filter

1.20 September 14, 2017
Isset checks evrywhere

1.21 September 20, 2017
Bug Fix and wp-signup.php

1.22 September 20, 2017
Minor bugfix and spelling error

1.23 September 22, 2017
Added contributor and php version

1.24 January 15, 2018
added nonce requirement to backend settings