WC Variations Radio Buttons

Описание

Radio buttons are more friendly than dropdown selects. This plugin will help you have a better UX in your WooCommerce site, as your customers will see all your variations without having to click on a dropdown.

The radio buttons will be toggled dinamically so your customers won’t be able to choose non existent variations.

Совместимость темы

This plugin may not work out of the box with some themes. This is due to a theme having its own template for variation selection (single-product/add-to-cart/variable.php).

To make this plugin work with a non compatible theme, a child theme has to be created.
Then copy plugins/wc-variations-radio-buttons/templates/single-product/add-to-cart/variable.php to themes/your-child-theme/woocommerce/single-product/add-to-cart/variable.php

GitHub

Source code and contributions at github

Отзывы

price disappears

When I click a radio button of an option, of which there is no product in the stock, the price of product disappears and appears back just if i reset the radiobutton selection.
Could you help me?
Thank you!

Посмотреть все 20 отзывов

Участники и разработчики

«WC Variations Radio Buttons» — проект с открытым исходным кодом. В развитие плагина внесли свой вклад следующие участники:

Участники

Перевести «WC Variations Radio Buttons» на ваш язык.

Заинтересованы в разработке?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Журнал изменений

2.0.0

  • Updated to match changes in WooCommerce 3.0.
  • This version is not compatible with WooCommerce 2.x.
  • Fix issues with the variation image not changing.

1.1.5

  • Fix error when using product_page WooCommerce shortcode.
  • Show alert when clicking disabled add to cart button.

1.1.4

  • Avoid overwriting of custom add-to-cart button.

1.1.3

  • Fixes clear button that got screwed on last version.

1.1.2

  • Updated to match changes in WooCommerce 2.5.
  • Image disappearing in certain themes fixed.

1.1.1

  • Support for responsive images as in WordPress 4.4 and WooCommerce 2.4.11.
  • Checked compatibility with WooCommerce 2.5.0-RC1.

1.1.0

  • Full compatibility with WooCommerce 2.4.
  • Variations are called via AJAX when there are many variations.
  • Changed version requirements: At least WordPress 4.1 and WooCommerce 2.4.

1.0.3

  • Now works with woocommerce_variation_is_active filter.
  • Fix bug that prevented the plugin to work with custom attributes.
  • Hopefuly no more «The plugin does not have a valid header.» message.

1.0.2

  • Now works better with some themes.

1.0.1

  • WooCommerce 2.4 compatibility.

1.0

  • Первый релиз.