YITH WooCommerce Minimum Maximum Quantity

Описание

If you are trying to limit the number of items that can be purchased from your WooCommerce shop by one user, YITH WooCommerce Minimum Maximum Quantity is what you are looking for. It is very useful to set a minimum quantity for WooCommerce items that can be added to the cart when their price is really small, either because sometimes shipping costs are much more expensive than single item cost or just because you are a wholesaler and you prefer dealing only with intermediaries instead of final customers. Set a minimum number of items and you can spare the nuisance and the embarrass of having to cancel orders containing less items than you can afford. We all know that even if you show users a huge notice message saying that they cannot purchase less than, say, 5 items, there always be someone that will place an order with 1 or 2 items. The only way to prevent them from doing that is to use some kind of restriction and YITH WooCommerce Minimum Maximum Quantity can help you with that.
The same goes for maximum quantity in WooCommerce cart. Are you wondering why you should limit sales? Think you are making a special offer and you don’t want that a few customers make rid of all items in stock with a few orders, what would be best than limiting maximum quantity of products in WooCommerce cart?

Features of YITH WooCommerce Minimum Maximum Quantity:

  • Enable/disable YITH WooCommerce Minimum Maximum Quantity from the option panel
  • Set minimum item quantity in WooCommerce cart
  • Set maximum item quantity in WooCommerce cart

Варианты

If you have suggestions about how to improve YITH WooCommerce Minimum Maximum Quantity, you can write us and contribute in making your YITH WooCommerce Minimum Maximum Quantity more and more performing.

Переводчики

Доступные языки

  • English

If you have created your own language pack, or have an update for an existing one, you can send gettext PO and MO file
use so we can bundle it into language pack of YITH WooCommerce Minimum Maximum Quantity.

Скриншоты

  • This is the settings page of YITH WooCommerce Minimum Maximum Quantity that you can find "YIT Plugins" menu. Use it to activate/deactivate plugin features and to set a minimum and maximum number of items to be added in the cart of your WooCommerce shop.
  • This image shows cart page of your WooCommerce shop showing the error message that informs users about the restriction limit they have not respected.

Установка

Установка

Important: First of all, you have to download and activate WooCommerce plugin, because without it YITH WooCommerce Minimum Maximum Quantity cannot work.

  1. Unzip the downloaded .zip file.
  2. Upload the YITH WooCommerce Minimum Maximum Quantity folder into the wp-content/plugins/ directory of your WordPress site.
  3. Activate YITH WooCommerce Minimum Maximum Quantity from Plugins page.

Настройки

YITH WooCommerce Minimum Maximum Quantity will add a new tab called «Minimum Maximum Quantity» in «YIT Plugins» menu. There, you will find all YIThemes plugins and you will be able to access quickly plugin settings page.

Часто задаваемые вопросы

Installation Instructions

Установка

Important: First of all, you have to download and activate WooCommerce plugin, because without it YITH WooCommerce Minimum Maximum Quantity cannot work.

  1. Unzip the downloaded .zip file.
  2. Upload the YITH WooCommerce Minimum Maximum Quantity folder into the wp-content/plugins/ directory of your WordPress site.
  3. Activate YITH WooCommerce Minimum Maximum Quantity from Plugins page.

Настройки

YITH WooCommerce Minimum Maximum Quantity will add a new tab called «Minimum Maximum Quantity» in «YIT Plugins» menu. There, you will find all YIThemes plugins and you will be able to access quickly plugin settings page.

Is it compatible with all WordPress themes?

Compatibility with all themes is impossible, because they are too many, but generally if themes are developed according to WordPress and WooCommerce guidelines, YITH plugins are compatible with them.
Yet, we can grant compatibility with themes developed by YIThemes, because they are constantly updated and tested with our plugins. Sometimes, especially when new versions are released, it might only require some time for them to be all updated, but you can be sure that they will be tested and will be working in a few days.

How can I get support if my WooCommerce plugin is not working?

If you have problems with our plugins or something is not working as it should, first follow this preliminary steps:

  • Test the plugin with a WordPress default theme, to be sure that the error is not caused by the theme you are currently using.
  • Deactivate all plugins you are using and check if the problem is still occurring.
  • Ensure that you plugin version, your theme version and your WordPress and WooCommerce version (if required) are updated and that the problem you are experiencing has not already been solved in a later plugin update.

If none of the previous listed actions helps you solve the problem, then, submit a ticket in the forum and describe your problem accurately, specify WordPress and WooCommerce versions you are using and any other information that might help us solve your problem as quickly as possible. Thanks!

Участники и разработчики

«YITH WooCommerce Minimum Maximum Quantity» — проект с открытым исходным кодом. В развитие плагина внесли свой вклад следующие участники:

Участники

«YITH WooCommerce Minimum Maximum Quantity» переведён на 3 языка. Благодарим переводчиков за их работу.

Перевести «YITH WooCommerce Minimum Maximum Quantity» на ваш язык.

Заинтересованы в разработке?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Журнал изменений

Version 1.2.8 — Released: Sept 20, 2017

  • Update: plugin framework

Version 1.2.5 — Released: Mar 23, 2017

  • Tweak: Support for WooCommerce 3.0.0-RC 1

Version 1.1.4 — Released: Jun 6, 2016

  • Tweak: support to WooCommerce 2.6.0 beta 4

Version 1.1.3 — Released: May 6, 2016

  • Fix: support for WooCommerce prior to 2.5

Version 1.1.2 — Released: Apr 14, 2016

  • Fix: support for WooCommerce prior to 2.5

Version 1.1.1 — Released: Apr 14, 2016

  • New: compatibility with WordPress 4.5

Version 1.0.9 — Released: Feb 17, 2016

  • Fix: WooCommerce deprecated function removed

Version 1.0.6 — Released: Dec 23, 2015

  • Update: language file
  • Fix: zero value on amount rule messages

Version 1.0.5 — Released: Dec 10, 2015

  • Fix: The notices in the cart still remains even if the conditions have been fulfilled

Version 1.0.4 — Released: Dec 09, 2015

  • Update: plugin core framework
  • Update: file class-yith-wc-custom-textarea.php

Version 1.0.3 — Released: Oct 30, 2015

  • Update: changed text domain from ywmmq to yith-woocommerce-minimum-maximum-quantity
  • Update: changed all language file for the new text domain

Version 1.0.2 — Released: Oct 29, 2015

  • Update: plugin core framework

Version 1.0.1 — Released: Sept 16, 2015

  • New: tab premium

Version 1.0.0 — Released: Sept 09, 2015

  • Первый релиз