Поддержка Темы и шаблоны Баннер в шапке не работает!

  • Здравствуйте, пмогите пожалуйста — баннер в шапке темы не хочет работать, тема нравиться блин — менять неохота, там есть Настройки в теме, поля ввода по Баннеры и всякие скрпты, ставлю стандартный код баннера — сохранить и ничего не работает. Вот сайт http://avtomagi.ru/ справа от логотипа на чёрном фоне должен быть Баннер, а он не покзыается. Почему?? Ничего не понимаю, менял путь к баннеру — неработает, менял код — так же…

Просмотр 12 ответов — с 1 по 12 (всего 12)
  • Да, в демо есть блок с классами «span-13 last», справа от «span-11», почему его нет у Вас остается только гадать.
    Первое, что приходит в голову — Вы неверно ставите «стандартный код баннера«.

    мне правда неизвестно что такое span-13 last», справа от «span-11» так ка в коде мало разбираюсь, код банера ставлю вот так

    <a href="http://avtomagi.ru/out.php?link=http://carsdeal.ru/?pid=5908&subid=5908&psn=221"><img class="alignnone size-full wp-image-44" style="border-image: initial; border: 0px initial initial;" title="Продажа подержанных автомобилей" src="http://avtomagi.ru/wp-content/avto.gif" alt="" width="468" height="60" /></a>

    Код верный, хоть и без ссылки, ссылка наверное отдельно. Проверьте, возможно, вывод баннера включается какой-либо дополнительной настройкой.

    да нет, там просто вставляешь в окно код и Жмёшь Сохранить, вссё сохраняется, но баннер не показывается почему-то…

    демо есть блок с классами «span-13 last», справа от «span-11»

    а чтоза Демо вы писали и где эти классы, а может из-за версии вордпресс?? хотя думаю вряд ли из-за этого может быть

    Демо — это демо используемой Вами темы. Когда я говорил про блоки, я имел ввиду, что место для баннера в теме предусмотрено и это видно по демо, у Вас этого блока нет. Т.е. еслибы был блок, но нет изображения или оно кривое, надо смотреть ссылку и пр., но так как нет больше чем просто изображение, нет блока его содержащего значит все несколько глубже, отсюда выводы:

    1. В теме есть настройки вывода баннера, т.е. вкл./выкл.
    2. В теме этот кусок вырезан на уровне кода
    3. Что-то еще

    а скажите, его можно как-то вручную просто Добавить этото недостающий косочек кода?? вот только знать бы куда его вставлять и какой именно 🙂

    Можно, легче легкого!

    Вот это:

    <div class="span-13 last">
    <div style="padding: 28px 0 0 0; text-align:center;">
    <a href="http://avtomagi.ru/">
    <img src="http://avtomagi.ru/wp-content/avto.gif" width="468" height="60" style="border: 0;" alt="Premium WordPress Themes" />
    </a>
    </div>
    </div>

    Сразу за закрывающим </div> т.е блока с классом «span-11».

    Это все располагается в header.php.

    Но обратите внимание, это не более чем код вписанный вручную, этот код не поможет восстановить плагин баннера. Таким образом плагин появится, но администрировать его в админке не получится!

    Эта тема платная, вероятно, в ознакомительной ее версии, код плагина баннера вырезан.

    Я не поленился и скачал тему, вероятно, не полную, однако код баннера там есть:

    <div class="span-13 last">
    <div style="padding: 28px 0 0 0; text-align:center;">
    <?php echo get_theme_option('ad_header'); ?>
    </div>
    </div>

    Проверьте у себя, есть такое? Если нет то стоит добавить или скачать заново тему и заменить header.php.

    хаа! прикольно 🙂 получилось, спасибо. вставил код вручную, вроде заработало

    skodnik,огромное Вам спасибо,у меня была такая же проблема,перелопатил кучу сайтов,везде все не то,вставил ваш код и баннер появился там где надо.

    // Рекламу - в другой раздел.
    Апельсинова

    Сделал как описанию. Баннер сполз куда-то вниз под логотип. Помогите настроить, плиз. Может другой код нужен для темы моего блога. Вот ссылка: http://x-cook.ru
    Надо чтобы рекламный баннер был на одной линии с лого, в шапке сайта.
    Там ввод ссылки баннера такой же как и у пользователя mogull.
    В настройке самой темы, есть поле ввода кода баннера 468×60. Ни один баннер не вставляется. Видимо тоже демо-версия шаблона.
    Помогите, плиз, кто знает как исправить.
    Спасибо заранее.

    maxcookertman, у Вас баннер в блоке с классами span-13 last, а надо поставить в блок с идентификатором header, сразу за закрывающим </div> блока с классом span-12.

    кстати, решил уже эту проблему сегодня вечером, методом просмотра кода через chrome, выявил проблемку. Да, да , я тоже потом допер что 12 индекс спана нужно поставить. И плюс, там я неправильно код вставлял после общего блока двойного закрытия скрипта </div> </div> , а надо было оказывается сразу в блоке шапке, где и логотип стоит, после первого </div>. Короче методом проб и ошибок все получилось. В любом случае спасибо Вам за помощь. Удачи всем!

Просмотр 12 ответов — с 1 по 12 (всего 12)
  • Тема «Баннер в шапке не работает!» закрыта для новых ответов.