Поддержка Обратная связь Ненасытный монстр

  • Решено Andrey Barmaley

    (@andrey-barmaley)


    Бло бы не плохо, если бы разработчики занялись бы проблемой потребления ресурсов wordpress. А то как, не выйдет обновление, так хоть свой дата центр покупай.

Просмотр 15 ответов — с 1 по 15 (всего 24)
  • А что мешает написать прямо наверх, создателю wordpress?? Я уже небольшой круг волонтеров напряг на сию просьбу. Пишите, через какое-то время всяко отреагируют :))

    Я почему то сомневаюсь, что письмо дойдёт. А если и дойдёт , то наверняка в спам корзину или просто останется непрочтённым. Да и сложно объяснять америкосам какие то технические вопросы. Такой у них унылый язык. Даже переводчик не поможет 🙂 Не то, что у нас можно более точно выразить суть проблемы.

    Примерно так:
    «Hi Matt! Created by you WordPress engine continues to develop dynamically. But with each new version requires more and more server resources. Becomes very difficult to find hosting meets the new requirements. Please take notice. Let the developers team to optimize the code. Thank you.»
    Без всяких технических терминов, на понятном русском :)))
    ===
    как в школе учили, так и перевел (то бишь критику в разумных пределах приму)

    Модератор Юрий

    (@yube)

    [offtop]
    И в Микрософт тоже надо написать! А то на машинку, на которой работала XPюша, ни в какую не хочет ставиться Семерка — требует гиг памяти :))))

    [offtop]

    требует гиг памяти :))))

    Есть такое дело… Я в твиттере уже писал БГ, но что-то без ответа пока.. Некогда видать…

    как в школе учили, так и перевел (то бишь критику в разумных пределах приму)

    Получше чем у меня текст письма 🙂

    Есть такое дело… Я в твиттере уже писал БГ, но что-то без ответа пока.. Некогда видать…

    По любому занет пересчитыванием денег срубленых с новой винды 😀

    Мне кажется когда wordpress начнёт потреблять без плагинов 30мб, то начнут , что либо предпринимать

    Модератор Юрий

    (@yube)

    когда wordpress начнёт потреблять без плагинов 30мб

    Тогда в default-constants.php пропишут

    if ( !defined('WP_MEMORY_LIMIT') ) {
    		if( is_multisite() ) {
    			define('WP_MEMORY_LIMIT', '128M');
    		} else {
    			define('WP_MEMORY_LIMIT', '64M');
    		}

    Andrew, что Вы скажете на этот скриншот?

    Andrew, что Вы скажете на этот скриншот?

    Даже не верится, что wordpress 3 метра всего использует. Это наверное сайт-каталог ссылок или простенький блог ?

    Модератор Юрий

    (@yube)

    Да я тоже обалдел, когда увидел эту цифру 🙂 WP был действительно почти пустой и без русского. Но 3М — это заслуга не пустоты, а eAcceleratorа. Без него WP изволит кушать 16M (проверял, отключал). Это на 32-разрядной системе, на 64-разрядной — в полтора-два раза больше.

    Ой, после включения обратно и рестарта apache показало 1.93M. А Вы говорите «монстр» :))))

    Так что:
    Вы не любите котов? Да вы просто не умеете их готовить!

    Юрий, настройки eAccellerator’а на обозрение выложите, сравню со своими, не забудьте memory_limit, Memory Available, Memory Allocated. :))

    Модератор Юрий

    (@yube)

    Ставил из портов. Дописал в php.ini:
    zend_extension=»/usr/local/lib/php/20060613/eaccelerator.so»
    eaccelerator.debug=»0″

    Не помню, чтобы еще что-то делал.

    А phpinfo что кажет?

    Модератор Юрий

    (@yube)

    eAccelerator support	enabled
    Version 	0.9.6.1
    Caching Enabled 	true
    Optimizer Enabled 	true
    Check mtime Enabled 	true
    Memory Size 	33,554,396 Bytes
    Memory Available 	15,504 Bytes
    Memory Allocated 	33,538,892 Bytes
    Cached Scripts 	294
    Removed Scripts 	0
    
    Directive	Local Value	Master Value
    eaccelerator.allowed_admin_path	no value	no value
    eaccelerator.cache_dir	/tmp/eaccelerator	/tmp/eaccelerator
    eaccelerator.check_mtime	1	1
    eaccelerator.debug	0	0
    eaccelerator.enable	1	1
    eaccelerator.filter	no value	no value
    eaccelerator.log_file	no value	no value
    eaccelerator.optimizer	1	1
    eaccelerator.shm_max	0	0
    eaccelerator.shm_only	0	0
    eaccelerator.shm_prune_period	0	0
    eaccelerator.shm_size	0	0
    eaccelerator.shm_ttl	0	0

    У меня только этим отличается, но результат почти такой же
    eaccelerator.shm_ttl 60
    eaccelerator.shm_size 32 //Если увеличить немного скорость вырастает
    Добавлено
    у меня memory_limit 128

    Модератор Юрий

    (@yube)

    У меня memory_limit master value сейчас 512M. Заталкивал в PMA 300-метровый дамп базы, пришлось ставить цифры, сопоставимые с физическими параметрами тазика.

Просмотр 15 ответов — с 1 по 15 (всего 24)
  • Тема «Ненасытный монстр» закрыта для новых ответов.