Поддержка WordPress Multisite Необходимость обновления WordPress MU

  • Здравствуйте,
    я создаю социальную сеть на основе WordPress MU 2.8.2 + Buddy Press 1.0.3 + bb Press 1.0.2.
    Сегодня зашла в админку и увидела, что вышла новая версия WordPress MU 2.8.3. Предлагается обновление.
    Скажите, стоит ли делать обновление? Или это внесёт диссонанс в работу всей системы?
    С уважением,
    Наталья

Просмотр 2 ответов — с 1 по 2 (всего 2)
  • Модератор Atrax

    (@atrax)

    Теоретически, ничем опасным обновление не грозит. Но я бы на вашем месте сначала запустил и отладил «как есть», затем сделал бы резервную копию всех файлов и базы данных и только потом бы обновлял компоненты.

    Сегодня утром обновился до MU 2.8.3. Но в ручном режиме! Как потом прочитал, проблема в файле class-wp-upgrader.php. В строке 697 прописан просто wordpress, а не wordpress-mu. Все работает корректно.

    Before upgrading, edit wp-admin/includes/class-wp-upgrader.php and look for line 697.

    if ( !$wp_filesystem->copy($working_dir . ‘/wordpress/wp-admin/includes/update-core.php’, $wp_dir . ‘wp-admin/includes/update-core.php’, true) ) {

    See the “/wordpress/wp-admin/includes” bit? Change that to “/wordpress-mu/wp-admin/includes”:

    if ( !$wp_filesystem->copy($working_dir . ‘/wordpress-mu/wp-admin/includes/update-core.php’, $wp_dir . ‘wp-admin/includes/update-core.php’, true) ) {

    Save the file and auto upgrade. I upgraded this afternoon without a hitch after making that change. It’s fixed in 2.8.3 so it’s the last time you’ll have to do it.

Просмотр 2 ответов — с 1 по 2 (всего 2)
  • Тема «Необходимость обновления WordPress MU» закрыта для новых ответов.