Поддержка Проблемы и решения Не могу востановить пароль.

  • В общем после обновления у меня на вордпресс начались следующие проблемы.
    — когда жмешь кнопку активировать или диактивировать плагин, появляется белый экран, приходится всё заного переходить в админ панель.
    — Решил востановить пароль, так как старым долго не пользовался и забыл. В общем жму восстановить пароль, на почту приходит письмо, где дана ссылка для сброса пароля, жму на неё и опять появляется белый экран.

    Посоветуйте как можно вернуть версию 4.3.2 или востановить пароль?

Просмотр 4 ответов — с 1 по 4 (всего 4)
  • Модератор Yui

    (@fierevere)

    ゆい

    смотрите лог ошибок сервера или выводите ошибку на экран

    возможно при обновлении заглючили какие то плагины или у вас несовместимая тема — переименуйте папку плагинов wp-content/plugins через фтп или файлменеджер хостинга, удалите лишние темы кроме тем twenty…

    также может помочь перезапись файлов через фтп из архива дистрибутива
    wp-includes, wp-admin, *.php
    нужной версии, новой или если хотите откатить — старой

    Если откатывать — лучше брать бэкап, на хостингах часто ежедневно делают

    ну и напоследок — https://codex.wordpress.org/%D0%A7%D0%90%D0%92%D0%9E/%D0%92%D0%BE%D1%81%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_%D0%BF%D0%B0%D1%80%D0%BE%D0%BB%D1%8F

    Попробовал включить лог ошибок, через wp-config.php не помогло.
    Далее переименовал папку с плагинами — это помогло. Стала известна причина, выдает вот такую ошибку теперь вместо белого экрана:

    Notice: Вызванный метод конструктора класса WP_Widget считается устаревшим с версии 4.3.0! Используйте

    __construct()

    . in /home/m/myworkhz/myworkpro.ru/public_html/wp-includes/functions.php on line 3457 Notice: Вызванный метод конструктора класса WP_Widget считается устаревшим с версии 4.3.0! Используйте

    __construct()

    Модератор Yui

    (@fierevere)

    ゆい

    Notice это не ошибка, к неработоспособности сайта она не приводит
    WP_Widget был обьявлен устаревшим в 4.3 и вызывал предупреждение
    в последующих версиях это должно перейти в ошибку

    wp-includes/functions.php on line 3457

    в ядре wp это не вызывается, у вас или файл подменен, или вызов шел с плагина или темы, но в сообщении это не видно

    ps: если акисмет сьел ваше сообщение, не пытайтесь запостить еще раз,
    это делает его еще более упрямым, лучше подождать , вы же в курсе как работает акисмет ? 😀

    Проблему удалось решить!
    Не мог востановить пароль, выдавало ошибку, лог ошибки я написал выше.
    Так же не мог зайти в админ панель, писали:

    ОШИБКА: Cookies заблокированы из-за неожиданного вывода на экран. Посмотрите документацию или обратитесь за помощью на форумы поддержки.

    Вначале перезалил более старую версию за сентябрь 2015.
    Потом пробовал пересохранить файлы wp-config.php и function.php в UTF-8 (без BOM). Ничего не помогло.

    В итоге проблема оказалась в теме блога, как вы и писали выше. Переименовал папку темы. Сайт перестал грузить, но форма входа в админ панель осталась работать и при этом данные ошибки исчезли. В общем я авторизовался, зашел в админ панель, обновил WordPress до версии 4.4.2.
    И всё стало работать нормально и конфликты с темой пропали. Всё стало работать так же хорошо, как и было до этого. А ошибка появилась скорее всего из за какого нибудь конфликта вызванного в результате авто-обновления.

    Спасибо за помощь!

Просмотр 4 ответов — с 1 по 4 (всего 4)
  • Тема «Не могу востановить пароль.» закрыта для новых ответов.