Поддержка Проблемы и решения Обновление WordPress

  • Всё началось с того что WordPress написал мне следующее: Не удаётся продолжить обновление, так как WordPress 3.2.1 требует PHP версии 5.2.4 или выше. У вас версия 4.4.4.
    Написал провайдеру, ответили:
    К сожалению информация в панели управления приведена для серверов новой
    конфигурации, т.е. для Вашего аккаунта она ошибочна.
    На сервере, где расположен Ваш аккаунт по-умолчанию все скрипты обрабатываются
    как php4 (mod http://swan.spaceweb.ru/phpinfo.php). Есть возможность
    обрабатывать скрипты как php5 (cgi http://swan.spaceweb.ru/phpinfo.php5)

    Чтобы подключить обработку скриптов как php5 в файл .htaccess Вам нужно
    прописать следующие строки:
    AddHandler php5-script .php
    Action php5-script /cgi-bin/php5.cgi

    Я прописал это в файл .htaccess, но сайт песрестал запускаться.
    Написал еще раз, ответили:

    Рекомендуем включить вывод ошибок PHP.
    Для вывода ошибок достаточно добавить следующие две строки
    php_value display_errors 1
    php_value error_reporting 2047
    в файл с именем .htaccess, размещающийся в папке public_html/ Вашего сайта.
    Отредактировать файл можно например в рaзделе «Файловый менеджер»
    https://cp.sweb.ru/files/
    Если файла .htaccess нет, то его следует создать.
    В разделе «Управление доменами» https://cp.sweb.ru/domains/ в колонке
    «Папка» при необходимости можно узнать, где именно размещается папка
    public_html/ Вашего сайта.
    После включения вывода ошибок, пожалуйста, повторите заход на Ваш сайт
    (нажмите F5 в браузере). Тогда на странице должна отобразиться отладочная
    информация, доступная по Вашему сайту. Эта информация должна помочь с
    определением причин возникших неполадок.

    А теперь подскажите мне пользователи форума что именно и как правильно написать мне в файл .htaccess

Просмотр 3 ответов — с 16 по 18 (всего 18)
  • Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Так может быть, если какая-то из четырёх строк сервером воспринимается некорректно. Поскольку все четыре строки предложила служба поддержки хостинг-провайдера, я не совсем понимаю, чем ещё можем помочь мы 🙂

    Версия WP 3.2.x требует по моим наблюдениям больше ресурсов
    По крайней мере на некоторых хостингах сайты перестали устанавливаться при памяти 32М (раньше устанавливались, но админ-панель работала криво).

    Может при включении отладки перестает чего-то хватать?

    Если файловый менеджер хостинга позволяет не отвлекаться на метку BOM и настройку FTP-клиента, когда проблема напрямую с ними не связана, то почему это плохо? 🙂

    В общем случае править файлы «онлайн» есть зло. Ибо много ньансов — от (пере)кодировок до преобразований «на стороне сервера».. как в момент передачи ПОСТ-запроса, так и в момент (пере)записи файла.
    А оно надо потом вылавливать баги в неожиданных местах?
    Нужно приучаться сразу делать правильно и надёжно.

    Может при включении отладки перестает чего-то хватать?

    Судя по ситуации — при внесении относительно безобидных строк проблема у хостера. Возможно они что-то не договорили…

    ЗЫ. у меня сайт сейчас открывается. Проблема решена?

Просмотр 3 ответов — с 16 по 18 (всего 18)
  • Тема «Обновление WordPress» закрыта для новых ответов.