• Нечайно сламал БД. Как исправить?
    wp_usermeta: Table is marked as crashed and last repair failed
    wp_posts: Table is marked as crashed and last repair failed
    wp_comments: Table is marked as crashed and last repair failed
    wp_options: Table is marked as crashed and last repair failed
    wp_postmeta: Table is marked as crashed and last repair failed
    wp_term_taxonomy: Table is marked as crashed and last repair failed
    wp_term_relationships: Table is marked as crashed and last repair failed

Просмотр 15 ответов — с 1 по 15 (всего 29)
  • Модератор Yui

    (@fierevere)

    永子

    войти в панель управления хостингом
    найти там phpMyAdmin
    выбрать все таблицы
    REPAIR (исправить)

    Автор John93

    (@john93)

    не помагает, выдает такую ошибку:
    wp_arp_arprice repair status Operation failed
    и так с остальними

    Модератор Yui

    (@fierevere)

    永子

    т.е. не чинится в phpMyAdmin ?

    обратитесь в техническую поддержку хостинга

    Автор John93

    (@john93)

    ето виртуалка

    Модератор Yui

    (@fierevere)

    永子

    в коммандной строке шелла:
    mysqlcheck -A -p -r

    ввести пароль для root (MySQL)

    ошибки смотреть в логе /var/lib/mysql/HOST.err

    где HOST — имя машины (обычно пишется в командной строке
    или ввести echo $HOSTNAME )

    tail -n 500 /var/lib/mysql/${HOSTNAME}.err

    в зависимости от дистрибутива может лежать и в другом месте
    (/var/log/mysql/ в этой папке например)

    Автор John93

    (@john93)

    Модератор Yui

    (@fierevere)

    永子

    попробуйте удалить файлы *.TMM в папке /var/lib/mysql/createdsites

    rm -fv /var/lib/mysql/createdsites/*.TMM

    и повторить

    mysqlcheck -A -p -r

    если есть *.TMD то и их тоже удалить

    Автор John93

    (@john93)

    Модератор Yui

    (@fierevere)

    永子

    очень мелко

    Модератор Yui

    (@fierevere)

    永子

    а у вас ФС не побитая случаем? или диск не переполнен? (df -h ; df -i )
    раздел /var

    также права посмотрите на папки /var/lib/mysql/*

    оно должно принадлежать пользователю mysql группа mysql (если в дистрибутиве вдруг не заведено иначе)

    Автор John93

    (@john93)

    4% использовано

    Автор John93

    (@john93)

    Автор John93

    (@john93)

    1

    Модератор Yui

    (@fierevere)

    永子

    ищите причину по которой mysqld не может писать в папку /var/lib/mysql/createsites

    Автор John93

    (@john93)

    ето наверное из за прав на папку. сейчас стоят 700 111/33

Просмотр 15 ответов — с 1 по 15 (всего 29)

Тема «Помогите восстановить БД» закрыта для новых ответов.