Поддержка Проблемы и решения Проблемы с Denwer’ом и WP

  • Я использую Denwer3 на Windows Vista Home Basic.

    После создания базы данных и рерактирования файла запускаю установку WP открывается страница установки но выше появляется предупреждение:

    «Warning: Cannot modify header information — headers already sent by (output started at Z:\home\test1.ru\www\wp-config.php:1) in Z:\home\test1.ru\www\wp-admin\install.php on line 36«

    Если просто открыть сайт (с еще не установленым WP) то выдается такое предупреждение:

    «Warning: Cannot modify header information — headers already sent by (output started at Z:\home\test1.ru\www\wp-config.php:1) in Z:\home\test1.ru\www\wp-includes\pluggable.php on line 865»

    Что это означает и как с этим боротся?

    Я думаю что возможно неправильно отредактировал wp-config.php, так как там нужно указывать пароль пользователя бд а при создании бд на дэнвере пароль пользователя не указывается. Если это так, то как решить эту проблему и вообще является ли это проблемой и что будет если с подобными предупреждения инсталировать WP?

Просмотр 4 ответов — с 1 по 4 (всего 4)
  • Модератор Юрий

    (@yube)

    Я думаю что возможно неправильно отредактировал wp-config.php

    Если быть совсем точным, то неправильно сохранили. Нужно сохранять в utf-8 без BOM. См. Вопросы и ответы

    Не это не подходит, только что пересохранил в utf-8 но ничего не изменилось, предупреждение как было так и осталось.

    Модератор Юрий

    (@yube)

    Сохраните wp-config.php в cp1251.

    Пересохранил в вордпаде как текстовый документ с юникодом, открыл страницу инсталяции — никаких предупреждений и ошибок.
    Спасибо за помощь.

Просмотр 4 ответов — с 1 по 4 (всего 4)
  • Тема «Проблемы с Denwer’ом и WP» закрыта для новых ответов.