Поддержка Разное Просто новости

  • Приветствую Сообщество и Коллег!

    Следите ли за новостями? 😉 Обновился апач до 2.4.6, закрыв несколько уязвимостей, вышел PHP 5.5.1 и, самое главное, объявлено о прекращении поддержки ветки 5.3.х. Готовы к переходу? 😀

    Пробежался по хостингам, что-то никто не торопится обновляться.. Плохо!

Просмотр 15 ответов — с 1 по 15 (всего 21)
  • Модератор Yui

    (@fierevere)

    永子

    Обновился апач до 2.4.6

    и 2.2.25 тоже

    объявлено о прекращении поддержки ветки 5.3.х.

    обновления безопасности еще год от команды разработки PHP

    Пробежался по хостингам, что-то никто не торопится обновляться..

    они смотрят в горы и вслушиваются а не свистнет ли там лобстер…
    как обычно. А вообще каждая установка WP сообщает статистику при проверке обновлений, вот что в итоге выходит http://wordpress.org/about/stats/ можно даже по хостингам не бегать и не смотреть (мне правда кается что этот график статистики тоже не особо торопятся обновлять)

    Учитывая то что хостинги обычно не лезут вперед паровоза, они обновятся тогда, когда будет готова инфраструктура, т.е. — обновления произойдут в дистрибутиве Linux (очень часто используют CentOS, а это сильно консервативный дистрибутив), будет готова поддержка в панелях управления хостингов. К сожалению есть вообще такие хостинги которые вообще боятся что-либо трогать, иногда даже в ущерб безопасности.
    Кстати заметили что на графике превалирует 5.2? Это при том что поддержка со стороны разработчиков была полностью прекращена, это опять же из за дистрибутивов, хорошо если RedHat/Debian поддерживают сами.

    кроме того есть ряд проблем с расширениями PHP

    — умерла поддержка suhosin, для 5.4 этого расширения нет
    — eAccelerator 0.9.x не поддерживается в 5.4, нужно использовать версию с GIT, а т.к. акселератор практически мертв, то для 5.5 поддержки нет даже в GIT, хотя там всего то убрать включение одного заголовка надо с php guid logo
    — для 5.5 нет поддержки APC, в связи с интеграцией ZendOpCache авторы APC прекратили дальнейшую разработку, для тех кому нужен кеш переменных — есть apcu
    — поддержка XCache для 5.5 пока доступна только в svn trunk (3.1.0-dev)

    когда будет готова инфраструктура, т.е. — обновления произойдут в дистрибутиве Linux

    ОГромный минус, что сказать.. Хорошо, что я виндузятник 😉 К тому времени, как только все перейдут на новенькое я уже все облапаю и заслюнявлю :)) [последнее, конечно, в кавычках :)]

    А вообще каждая установка WP сообщает статистику при проверке обновлений, вот что в итоге выходит

    Это не все. Там собирается много какой информации, например, количество пользователей, комментариев, какие плагины, темы используются и т.п.. В свете последних новостей о глобальном шпионаже не нравится мне это.. 😉

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    мне правда кается что этот график статистики тоже не особо торопятся обновлять

    Статистика на WordPress.org обновляется раз в сутки:
    http://make.wordpress.org/core/2010/08/31/previously-wed-talked-about-putting-up/

    Модератор Yui

    (@fierevere)

    永子

    Статистика на WordPress.org обновляется раз в сутки:

    спасибо, т.е. она актуальна

    ОГромный минус, что сказать

    это не минус, учитывая огромное количество дистрибутивов linux, каждый дистрибутив сам определяет политики обновления, так уж получилось что львиная доля на серверах — самые консервативные дистрибутивы, хотя удивляться нечему. На вендах да, там нет централизации обновлений, вышло что-то — иди на сайт производителя, качай, ставь, в случае конфликтов версий и прочих проблем — разбирайся самостоятельно. В линуксах никто не запрещает ставить новое и вообще всячески экспериментировать, некоторые хостинги сами собирают свою php вручную,
    большинство же — дистрибутивная политика обновлений, реже — подключены сторонние репозитории, предоставляющие опции или более новую версию.

    К тому времени, как только все перейдут на новенькое я уже все облапаю

    также как и «красноглазые» пользователи дистрибутивов для «красноглазых», они это сделают гораздо быстрее, по сути это альфа-бета тестеры. Gentoo, Arch.

    Это не все. Там собирается много какой информации, например, количество пользователей, комментариев, какие плагины, темы используются и т.п

    http://api.wordpress.org/core/version-check/1.6/?version=3.5.2&php=5.5.1-Yui&locale=en_US&mysql=5.5.32&local_package=&blogs=1&users=2&multisite_enabled=0
    http://api.wordpress.org/plugins/update-check/1.0/
    http://api.wordpress.org/core/browse-happy/1.0/

    первый POST в принципе и есть формирование того графика статистики, количество комментариев я там не вижу 🙂
    второе — проверка плагинов и тем
    третье — проверка браузера администратора, имхо — излишество

    также могут быть дополнительные проверки на сторонние сервера, обычно в платных темах есть проверка актуальности тем на серверах разработчиков этих тем.

    Модератор Yuri

    (@yube)

    Пробежался по хостингам, что-то никто не торопится обновляться.. Плохо!

    Как сказать. На сайтах стоят разные движки, и не все они обновляются также оперативно, как wordpress. Да и wordpress, кстати, тоже не все бегом обновляют по, надеюсь, понятным причинам. Так вот, у старых движков с php5.3 имеются разногласия, а с 5.4 так просто вооруженный конфликт.

    P.S. Не люблю хотсеров с зудом в руках. Наш девиз: «не сломалось — не чини».

    Как сказать. На сайтах стоят разные движки, и не все они обновляются также оперативно, как wordpress.

    Я про старье ничего не говорил, я говорил о предложении вообще. Из десятка хостеров нигде нет желтенькой звездочки со словами «Только у нас, PHP 5.5» 🙂 Выбора-а не-е-ет.. Скоро рассве-е-ет.. :))))

    количество комментариев я там не вижу 🙂

    Мог и ошибиться.. Главное, что собирают.. 🙂

    Модератор Yuri

    (@yube)

    Ой вэй 🙂 Берите VDS и ставьте себе что угодно, хоть PHP 6.6.6

    Берите VDS

    Так то понятно… У меня же нет опыта с этими ВДСами, зачем людей смешить? 🙂 Настроить все-равно не смогу, а пока разберусь что к чему, так и шареды подоспеют..

    Модератор Yui

    (@fierevere)

    永子

    вот кстати насчет совместимости,
    у меня на одном сервере (wordpress-ы, drupal, gallery2-3 разная мелочь типа вебмейла) версия 5.5.x хорошо встала и работает
    на другом (drupal, разная ерунда типа tt-tss, gallery2-3, SMF) установка 5.5 провоцирует SMF на активную ругань в логи по поводу deprecated функций,

    исправлять ругань не хочется, хоть и не сложно, просто потом SMF может иметь проблемы с самообновлением, проще подождать пока это сделают его неторопливые разработчики

    У меня же нет опыта с этими ВДСами

    вот вот, поставите centos или debian и будете сидеть на старой версии,
    в лучшем случае ubuntu с сторонними репозиториями 🙂 Или все же arch или gentoo ? А может вручную полезете собирать через ./configure && make && make install ?

    нет желтенькой звездочки со словами «Только у нас, PHP 5.5»

    да оно и не востребовано, новые возможности практически нигде еще не внедрены, 5.5 версия больше для разработчиков… Что уж говорить, если авторы PHP расширений еще не подтянулись

    Наш девиз: «не сломалось — не чини».

    главное чтобы это не переходило в крайности, когда этим уже занимаются археологи.

    Жизненный цикл PHP вполне себе позволяет сидеть на 5.3 до весны 2014, из-за заторможенности хостеров по переходу длительная поддержка безопасности ветки 5.2 была обещана разработчиком suhosin, только вот он сам после этого куда-то пропал. Еще среди разработчиков PHP ходят рекомендации об обновлении старых версий до 5.5, минуя ветку 5.4, возможно срок ее поддержки будет сокращен.

    вот вот, поставите centos или debian и будете сидеть на старой версии

    🙂 Да я даже ставить не буду. В моем возрасте уже нет смысла переучиваться на другую ось. Там же все по другому, не как в родных окошках :))

    А может вручную полезете собирать через ./configure && make && make install ?

    Ага, когда первый раз попробовал, нифига не получилось, потом месяц на книжки потратил и о, чудо, свершилось, сам собрал пхп со своими настройками.. Оказывается и не так все сложно 😉

    [off]
    Вот был бы под рукой второй комп я бы под сервер его поставил (на окошках, конечно :D), у меня канал чистая сотка, для блога с парой сотней гостей в день — за глаза хватит..

    Модератор Yui

    (@fierevere)

    永子

    смысл есть всегда, особенно в возрасте, тренировка ума препятствует старению 🙂 да и не сильно сложно это, хорошие варианты (на мой взгляд) для новичков — ubuntu server или наш altlinux (там есть удобная панелька управления через браузер)

    PHP кстати сложно собирать вручную в сравнении с большинством другого софта, там много ключиков и среди них есть конфликты и взаимозависимости

    Модератор Yuri

    (@yube)

    главное чтобы это не переходило в крайности, когда этим уже занимаются археологи.

    И киберпалеонтологией тоже приходится заниматься 😉

    Вот был бы под рукой второй комп

    Отдам P-III в хорошие руки, самовывоз 🙂

    [офф]

    Отдам P-III в хорошие руки, самовывоз 🙂

    Если из Сибири в Першу столицю никто не поедет за таким добром, то вот кое-каким моим знакомым харьковчанам мб и пригодился бы. Не намылите конфигурацию? Мб их заинтересует.
    [/офф]

    тренировка ума препятствует старению 🙂

    Это точно :))

    для новичков — ubuntu

    Попробовал я ubuntu, даже у Юрия спрашивал совета, запустил, а он сетевую не видит.. После часа волнений узнал, что надо перед каждым запуском сбрасывать настройки сетевой карты.. Бред какой-то (я уже подробностей не помню, что там и куда прописывать), но после этого я утвердился в мысли, что это не для меня. 🙂

    PHP кстати сложно собирать вручную

    Да я целый месяц потратил на это. Когда бложик заведу свой, напишу как собирать PHP на окошках абсолютному новичку 🙂

    Отдам P-III в хорошие руки, самовывоз 🙂

    Круто :)) Только далековато мне ехать придется :)))

    Модератор Yuri

    (@yube)

    кое-каким моим знакомым

    Только моим 😉

    Не намылите конфигурацию?

    Я просто не помню, что есть, в каком состоянии и где валяется. По случаю приезда wikicms я бы собрал до кучи, а так лень 🙂

    а он сетевую не видит..

    Было с линухом такое дело. После FreeBSD это оказалось для меня большим сюрпризом.

Просмотр 15 ответов — с 1 по 15 (всего 21)
  • Тема «Просто новости» закрыта для новых ответов.