• Писал сюда с проблемой, но никто так и не смог помочь.
    Постараюсь подробнее объяснить что происходит.
    Поставил пароль на папку wp-admin. В этой папке лежит вот такой htaccess

    AuthGroupFile /dev/null
    AuthType Basic
    AuthUserFile /home/префикс БД/domains/мойсайт.ru/.htpasswd/public_html/wp-admin/.htpasswd
    AuthName "Member's Area"
    require valid-user

    Всё работает прекрасно.

    В настройках Постоянных ссылок выставляю произвольную структуру вида /%category%/%postname%/
    Вот так ой становится htaccess после применения настроек:

    <Files .htaccess>
    order allow,deny
    deny from all
    </Files>
    
    Options +FollowSymLinks
     RewriteEngine On
     RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
     RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
     RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
     RewriteRule ^(.*)$ index.php [F,L]
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Опять же вся структура работает отлично: категории, посты, подкатегории

    Но при попытке войти сайт.ру/wp-admin/ — Ошибка 404
    Если исключить дополнительную защиту админской папки, то в wp-admin заходит спокойно, или же наоборот помогает отключение ЧПУ без отключения дополнительного пароля на админскую папку.

    Трехдневный поиск по интернету вывел меня только на одного челоека с подобной проблемой, которую он так и не решил.

    Как по мне, тут причина кроется в RewriteRule ^index\.php$ — [L]. В php я не силен, т.к. разбираюсь только в хтмл.

    Выручайте! Буду очень признателен!

Просмотр 4 ответов — с 1 по 4 (всего 4)
  • Модератор Юрій

    (@yube)

    По-моему, с .htaccess лучше идти на форум поддержки Апача. Или к тому, кто посоветовал вставить код

    Options +FollowSymLinks
     RewriteEngine On
     RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
     RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
     RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
     RewriteRule ^(.*)$ index.php [F,L]

    Без него, я думаю, будет нормально работать. По крайней мере, у меня всё замечательно работает со стандартным кодом wordpress в корневом .htaccess и require valid-user в /wp-admin/

    Options +FollowSymLinks, по-моему от XSS атаки, заметил что с этим кодом сайт только в Опере бывает долго грузится, около 5 секунд. К сожалению удаление этого кода, к положительному результату не привело, всё так же 404.

    На англоязычном форуме нашел подобную тему. Читать по английски еще не разучился и по совету прописал в htaccess, который в wp-admin строку ErrorDocument 401 default и всё зааработало. Спасибо Вам, Юрий за помощь)

    Модератор Юрій

    (@yube)

    Вам спасибо. Надо будет где-то сохранить эту волшебную строку ErrorDocument 401 default на всякий случай.

Просмотр 4 ответов — с 1 по 4 (всего 4)
  • Тема «ЧПУ. Не могу зайти в админку» закрыта для новых ответов.