Поддержка Проблемы и решения Автодобавление тегов в пользовательский код добавленный через «Текст»

  • В код, который я сам добавляю на страницы бывает добавляются теги <p>. Самих тегов в админке, в меню редактирования странице на вкладке редактора «Текст», нету. Их видно только через просмотр кода страницы в браузере.

    Происходит не всегда, редко и выборочно вокруг некоторых элементов (которые находятся в одном родительском контейнере с другими элементами, у которых свой родитель, но их родитель — общий).

    Пример: (text01 будет обрамлен <p>)
    <div> <h2>text00</h2> text01 <h3>text02</h3> </div>

    Кусок исходного кода:
    <div>... организовывает <h4 class="font_size_07vw vertical_align_top display_inline"> экскурсионные туры в Чехию с включенным прямым перелетом из Одессы </h4> в Прагу ...</div>

    Итоговый код:
    <div> <p>... организовывает </p><h4 class="font_size_07vw vertical_align_top display_inline"> экскурсионные туры в Чехию с включенным прямым перелетом из Одессы</h4> <p> в Прагу ... </p> </div>

    Происходит это не на всех страницах. Как отключить подобное автодобавление тегов <p>?

    По двум ссылкам ниже добавлен один и тот же код (к основному содержимому), но на первой странице туда как-то добавлены теги <p>, а ко второй — нет. Соответственно по первой ссылке все перекорячено и не работает как задумывалось, а по второй — все норм.

    Страница с автодобавленными тегами <p>
    Страница без автодобавленных тегов <p>

    WordPress 5.1.1

    • Тема изменена 10 месяцев, 1 неделя назад пользователем globurs.
    • Тема изменена 10 месяцев, 1 неделя назад пользователем globurs.
    • Тема изменена 10 месяцев, 1 неделя назад пользователем globurs.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 3 ответов — с 1 по 3 (всего 3)
  • Решил проблему плагином Raw HTML, все работает как надо, спасибо создателю плагина =)

    Также пробовал прописывать в functions.php следующий код (не помогло):

    /* Disable auto-add tags in the post */ 
    remove_filter( 'the_content', 'wpautop' );
    /* Disable auto-tagging in the announcement */
    remove_filter( 'the_excerpt', 'wpautop' );
    /* Remove the <p> tag from images */
    function img_unautop($pee) {
        $pee = preg_replace('/<p>\\s*?(<a .*?><img.*?><\\/a>|<img.*?>)?\\s*<\\/p>/s', '<figure>$1</figure>', $pee);
        return $pee;
    }
    add_filter( 'the_content', 'img_unautop', 30 );
    // Отключаем автоформатирование в комментариях
    remove_filter('comment_text', 'wpautop');
    remove_filter('the_content', 'wptexturize');

    Также пробовал устанавливать Advanced TinyMCE Configuration и устанавливать для параметра «wpautop» значение «false», но также не помогло.

    Решил проблему еще раз, другим способом, более удобным и универсальным.
    Так как Raw HTML не всегда работал.
    Плагин «Advanced Custom Fields», тип поля «Область текста», Перевод строк (Способ перевода строк) «Без форматирования».
    Всё!
    Работает всегда и везде =)

    На данный момент Работает всегда и везде =)

    поправил, не благодарите.

Просмотр 3 ответов — с 1 по 3 (всего 3)
  • Тема «Автодобавление тегов в пользовательский код добавленный через «Текст»» закрыта для новых ответов.