Поддержка Проблемы и решения Белый экран вместо страниц

  • Доброго времени суток!
    У меня возникла проблема — созданные страницы в Вордпресс показывают белый экран. При создании новой страницы — то же самое.
    Вначале при включении опции define(‘WP_DEBUG’, true); показывал проблему в плагине. Деактивировала его. Теперь вообще не показывает никакой ошибки, просто белый экран.

    Пробовала деактивировать все плагины.
    При попытке очистить кэш выдал было ошибку на /wp-includes/functions.php:4115. Пробовала заменить этот файл новым со свежеустановленной Вордпресс. Ноль эффекта.
    При define(‘WP_DEBUG’, false); кэш очищается нормально, хотя не вижу связи.
    Переустановила последнее обновление Вордпресс.
    К сожалению, я на эти страницы (они в меню) давно не заходила и не могу сказать, когда точно они накрылись. Но не позднее месяца назад. С главной страницей и записями порядок.
    Да, пыталась увидеть код ошибки, вставив в .htaccess php_flag log_errors on. Ни черта, не показывает ошибку всё равно, белый экран и всё.
    Заранее спасибо за помощь!

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 15 ответов — с 1 по 15 (всего 15)
  • Возможно у Вас хостер ограничил в выводе ошибок.
    Обратитесь к нему.

    Можно так же включить локальную запись ошибок, но это вряд ли поможет, если их нет в «обычных» логах.

    И я вижу PHP/5.3.28. Стоит перейти хотя бы на 5,6, а лучше на 7,2.

    И кеш-плагины отключите, очистив кеш.

    Модератор Yui

    (@fierevere)

    ゆい

    в админку войти можете?
    Попробуйте переключиться на другую тему, возможно что-то из twenty

    Белый экран у вас кстати не выдает ошибки, там статус ответа 200
    т.е. просто пустая белая страница, без ничего.

    < HTTP/1.1 200 OK
    < Date: Sat, 16 Feb 2019 20:52:55 GMT
    < Server: nginx/1.14.0
    < Content-Type: text/html; charset=UTF-8
    < Content-Length: 0
    < X-Powered-By: PHP/5.3.28
    < Vary: Accept-Encoding,Cookie
    < Link: <http://talkingdogs.ru/wp-json/>; rel="https://api.w.org/", <http://talkingdogs.ru/?p=868>; rel=shortlink
    

    О, у вас на главной.. какой-то жуткий не порядок. Откуда-то взялись заголовки плагина.

    Наверняка Вы что-то «наколдовали» с дочерней темой.

    Откуда-то взялись заголовки плагина.

    Я тоже использую плагин Subtitles (для вывода подзаголовков постов) на двух сайтах и у меня он тоже оставляет свои следы в исходном коде страниц на обоих сайтах
    http://joxi.ru/DmB8q9aCweVbQA?d=1

    Однако никаких проблем из-за этого за последние 4 года не наблюдалось. http://joxi.ru/DmB8q9aCweVeQA

    PS но на сайте ТС http://talkingdogs.ru/ я нигде не увидел подзаголовков записей или страниц. Значит плагин установлен просто так и не используется.

    • Ответ изменён 1 год, 3 месяца назад пользователем O.
    • Ответ изменён 1 год, 3 месяца назад пользователем O.
    • Ответ изменён 1 год, 3 месяца назад пользователем O.

    и у меня он тоже оставляет свои следы в исходном коде страниц на обоих сайтах

    Да, оказывается так и есть. Какой ужас..

    Добрый день!
    Большое спасибо всем за помощь!
    Выяснилось следующее — действительно, при смене темы страницы появляются!
    Не подскажете, где в теме может быть этот трабл, чтобы его исправить? (непонятно, кстати, как это поломалось, единственное, что я правила в последнее время в теме, была установка мета-тега Яндекса для подтверждения прав в Вебмастере).

    Плагин Subtitles, действительно, может и стоит удалить, я его использовала пару раз всего.

    Не подскажете, где в теме может быть этот трабл, чтобы его исправить?

    Лучше обратиться к автору темы.

    Еще один вопрос напоследок! :))
    Я поставила локально Вордпресс и работала с ним параллельно с Вордпрессом на хостинге. При этом был запущен Хampp. Мог ли он каким-то образом повлиять на работу Вордпресс на хостинге? Мне показалось, что проблемы начались, как только я начала эту паралелльную работу (перетаскивала файлы настроек дочерней темы с сервера по ftp).

    Модератор Yui

    (@fierevere)

    ゆい

    смотря как переносили файлы и базу, чем, кстати переносили?

    Просто перетащила по FTP с сервера на комп и всё.

    Тогда похоже вы потихоньку портите ту базу, что осталась на хостинге.

    А каким образом она портится? От включения Хampp? Исходные файлы не могут же испортиться от простого копирования?
    И я не трогала никакие файлы конкретно вордпресс, только те, что лежали в дочерней теме — футер, хедер, style.css, вот это всё. Я их просто скопировала.

    • Ответ изменён 1 год, 3 месяца назад пользователем KsuWarlock.

    А каким образом она портится?

    Если Вы перетянули только файлы, без базы, то работаете с базой на хостинге. Если с базой и в конфиге прописан localhost, то на хостинге может и не портиться, но «перетянули» не правильно
    См https://ru.stackoverflow.com/questions/767561/%D0%9A%D0%B0%D0%BA-%D0%BF%D1%80%D0%B0%D0%B2%D0%B8%D0%BB%D1%8C%D0%BD%D0%BE-%D0%BF%D0%B5%D1%80%D0%B5%D0%BD%D0%B5%D1%81%D1%82%D0%B8-%D1%81%D0%B0%D0%B9%D1%82-%D0%BD%D0%B0-wordpress/

    В вообще это уже второй вопрос. См правила форума, п2.

    Прошу прощения!
    Спасибо за помощь!

Просмотр 15 ответов — с 1 по 15 (всего 15)
  • Тема «Белый экран вместо страниц» закрыта для новых ответов.