Поддержка Проблемы и решения Виджет для расширения BuddyPress

  • Здравствуйте. Вообщем не знаю правильно ли выражаюсь но поясню так
    установлено расширение buddypress и есть у меня два пользователя ссылки выглядят примерно так
    ************ru/polzovateli/tr090- автор
    ************ru/polzovateli/admin — админ
    вообщем это как бы профиля пользователей (расширенная информация) и туда можно внести различные виджеты. поле называется buddyДом и туда можно положить любые виджеты
    но дело в том, что мне нужно создать виджет для каждого пользователя свой то есть я создаю определённый виджет с одними настройками возьмем рубрики для пользователя trr0909 будут отображаться из 5 категорий существующих только 4 указанных мною в параметрах ну или не важно любой статичный код если я создам
    и далее те же рубрики для админа которые задавались для trr0909 будут недоступны и админу нужно задать свои параметры для рубрик у него будут отображаться все рубрики 5 из 5.
    и так далее для каждого нового пользователя буду создавать отдельный виджет с определенными настройками и который будет недоступен в остальных профилях не знаю правильно ли выразился..

    • Тема изменена 3 года, 1 месяц назад пользователем unser1.
Просмотр 5 ответов — с 1 по 5 (всего 5)
  • разобрался помогло два виджета Dynamic Widgets и User role editor может кому то пригодится

    Автор unser1

    (@unser1)

    но и вообще расширение buddypress не рекомендую сырое

    сырое

    — вы просто не умеете его готовить.
    p.s. странно почему у «сырого» 200 тыс активных установок.
    С «мастером» видать что-то не так. А не с инструментом.

    С «мастером» видать что-то не так. А не с инструментом

    «Мастер» уже показал свой уровень, когда назвал Let’s Encrypt плагином 🙂

    Модератор Yui

    (@fierevere)

    永子

    для LE были плагины, реализующие авторизацию сайте через ACME
    ( url /.well-known/ )

    но использовать их — еще то мучение было,
    во-первых они глючили

    во-вторых…. сертификат складывался в папку плагина или где-то внутри wp-content, то есть его еще нужно было установить
    (а это может сделать только системный администратор сервера (root))

    поэтому лучше это не использовать,
    поддержка LetsEncrypt есть и в CPanel и Plesk и в других хоть немного себя уважающих панельках управления хостингом, где этому функционалу как раз самое место.

Просмотр 5 ответов — с 1 по 5 (всего 5)
  • Тема «Виджет для расширения BuddyPress» закрыта для новых ответов.