Поддержка Проблемы и решения Зависает видео

  • Доброго времени суток. В какой-то момент сломалось воспроизведение видео. При загрузке страницы должно автоматически проигрываться видео. И вот оно на первом кадре замирает и всё. И логотип, который внизу, тоже не крутится (это тоже видео, но формате webm).
    Интересен момент, что обновление F5 страницы не помогает, а если нажать на логотип, то попадаешь опять сюда же и видео уже крутится.
    Раньше всё воспроизводилось.
    Вот как видео размещено на сайте
    <div class=»fullscreen-bg»>
    <video id=»mainvideo» class=»fullscreen-bg__video» autoplay loop=»loop»>
    <source src=»http://vcinema.pro/wp-content/uploads/2018/08/SOS_GLAVNAYA.mp4&#8243; type=»video/mp4″ />
    <source src=»http://vcinema.pro/wp-content/uploads/2018/08/SOS_GLAVNAYA.webm&#187; type=»video/WebM» />

    </video>
    </div>

    .fullscreen-bg {
    overflow: hidden;
    position: relative;
    height: 100%;
    width: 100%;
    padding-top:45%;
    }

    .fullscreen-bg__video {
    position: absolute;
    top: 0;
    left: 0;
    width: 100%;
    }

    Очень вас прошу помогите!!!! Я уже всю голову сломала (((.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 8 ответов — с 1 по 8 (всего 8)
  • Ваше видео — 74мб и продолжительностью 1,5 минуты. Да ещё со звуком. Плюс как вы говорите ещё одно видео-логотип. Не многовато ли для шапки сайта?

    Модератор Yui

    (@fierevere)

    ゆい

    многие браузеры сейчас отключили автовоспроизведение видео

    а почему после нажатия на логотип (т.е. фактически повторного входа на сайт) видео начинает автоматически воспроизводиться?
    Это не может быть связано как-то с самим вордпресс? Я пробовала вставить видео через [video] т.е. с помощью спецификации WP, оно нормально проигрывалось, но у меня не получилось растянуть видео на всю ширину экрана.

    Извините, а как-то можно это исправить, какой-нибудь костыль есть для того, чтобы видео запускалось?
    Заранее спасибо.

    Аналогичная проблема, на 4 сайтах перестало воспроизводиться фоновое видео. После внутренних переходов по лого или ссылкам видео запускается Решения нет?

    Решения нет?

    пользоваться правильным браузером — firefox

    дело в том, что гугл изменил политику для воспроизведения автоплея в своем браузере (хроме).
    https://developers.google.com/web/updates/2017/09/autoplay-policy-changes
    Я не вчитывалась, но вроде гугл предлагает решение. У меня не фоновое, поэтому я просто сделала по нажатию.

    • Ответ изменён 3 года, 4 месяца назад пользователем rognarek.
    Модератор Yui

    (@fierevere)

    ゆい

        Muted autoplay is always allowed.
        Autoplay with sound is allowed if:
            User has interacted with the domain (click, tap, etc.).
            On desktop, the user's Media Engagement Index threshold has been crossed, meaning the user has previously play video with sound.
            On mobile, the user has added the site to his or her home screen.
        Top frames can delegate autoplay permission to their iframes to allow autoplay with sound.

    интересные политики
    особенно про индекс вовлеченности

Просмотр 8 ответов — с 1 по 8 (всего 8)
  • Тема «Зависает видео» закрыта для новых ответов.