Поддержка Проблемы и решения Исчезли изображения после обновления до 4.5

  • Решено Sergey Kovalets

    (@sergeykovalets)


    Приветствую друзья.
    Юзаю тему Twenty FourteenВерсия: 1.7 (Последняя версия)
    Так же плагин: Fourteen Colors
    Обновил плагин вчера, всё было ок, а сегодня тему и сам движок одновременно, и получилась проблема.

    Все загружаемые файлы загружаются в папку media, а не в wp-content (мне так больше нравится)
    Настроено это было через wp-config.php командой define(‘UPLOADS’, ‘media’);

    Много лет всё это работало отлично, но вот с обновление на 4.5 перестали отображаться картинки в постах, определил что ссылки на файлы ведут не верно, то есть, вместо site.com/media/2016/03/proxy.jpg отображается теперь site.com/wp-content/2016/03/proxy.jpg

    Так же зайдя в «Медиафайлы» в админке так только разорванные иконки, то есть картинок нет. При нажатии на медиафайл в ссылке так же сменилась ссылка с media на wp-content

    Пока что частично решил вопрос командой add_filter( ‘max_srcset_image_width’, create_function( », ‘return 1;’ ) ); добавленной в functions.php
    но в медиафайлах все равно нет изображений, хоть в постах появились.

    пробовал загрузить новый медиафайл но он загрузился и его сразу нет, ищет файл в папке wp-content, строчку define(‘UPLOADS’, ‘media’); в wp-config.php я так понимаю вордпресс почему то игнорит.

    В чем может быть проблема? ведь тема дефолтная и плагин.

Просмотр 7 ответов — с 1 по 7 (всего 7)
  • Модератор Denis Yanchevskiy

    (@denisco)

    WordPress-разработчик, wpcute.ru

    Походу баг.

    Только что запустил свой тестовый сервер, восстановил бэкап своего сайта на нем и все по очереди обновил.

    Проблема в плагине WordPress Popular Posts
    если его отключить то всё норм.

    Уже написал разработчику что бы обновил плагин.

    Hi guys!

    I don’t speak russian so I’ll write in english instead.

    This issue sounds more like a WordPress bug than something caused by WordPress Popular Posts (or any other plugin out there). Please read here for more.

    Модератор Yui

    (@fierevere)

    ゆい

    Hector Cabrera, denisco already gave same link and topic starter marked issue as resolved for him.

    My apologies. As I said, I don’t speak russian and didn’t check denisco’s link. Since WordPress Popular Posts is being mentioned here as the cause of the problem (and since I’m the developer behind WPP) I thought I had to chime in and share that link.

    Anyways, thanks for the notice!

    Модератор Yui

    (@fierevere)

    ゆい

    Hector, Sergey mentioned that the problem root was in placing define’s wrongly in wp-config.php (after That’s all, stop editing! Happy blogging. line)

    he says sorry for disturbing you 😀

    No harm done, so don’t worry 🙂 (and thanks for translating!)

Просмотр 7 ответов — с 1 по 7 (всего 7)
  • Тема «Исчезли изображения после обновления до 4.5» закрыта для новых ответов.