• Здравствуйте! У меня на хостинге обновили PHP до версии 5.3 и исчез Elementor. Весь сайт поплыл. Написала на хостинг в помощь поддержки они мне PHP обновили до другой версии. Сейчас все отобразилось опять. Проверьте пожалуйста в чем была проблема, не хотелось бы такого стресса опять. Я уже перепугалась, что весь сайт придется переделывать заново.

    Заранее спасибо!
    Елена

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 6 ответов — с 1 по 6 (всего 6)
  • Модератор Yui

    (@fierevere)

    ゆい

    «обновили до версии 5.3» это было сказано очень мощно
    на настоящий момент поддержка PHP ниже версии 5.6 прекращена. Поддержка версий 5.6 и 7.0 заканчивается к новому году.
    Актуальны — 7.1 7.2

    https://ru.wordpress.org/support/upgrade-php/

    что произошло с плагином можете посмотреть в логе ошибок сервера (PHP)
    возможно на сборке PHP ему чего-то не хватило.
    Делайте резервные копии, они добавят уверенности и возможности восстановления, если что-то пойдет не так.

    Yui (@fierevere), я не знаю может мы о разных вещах говорим, я не очень хорошо еще понимаю в сайтах, т.к. это мой первый опыт, но я написала вам то, что написала мне служба поддержки от TimeWeb.
    «Однако, в логах действительно есть ошибка плагина:
    Oct 19 14:45:13 vh140 apache_error: webdesignfocus.ru [Fri Oct 19 14:45:13 2018] [error] [pid 22761] sapi_apache2.c(326): [client 95.130.167.132:34454] PHP Warning: mysql_fetch_array() expects parameter 1 to be resource, boolean given in /home/c/cn42960/wordpress/public_html/wp-content/plugins/ultimate-plugins-smart-update-pinger/ultimate-plugins-smart-update-pinger.php on line 99

    Вероятно, плагин не совместим с используемой Вами в данный момент версией PHP 5,3.
    К сожалению, анализ пользовательского кода выходит за рамки компетенции поддержки хостинга, и по данному вопросу Вам необходимо обратиться к разработчику сайта или к документации (или поддержке) используемой CMS.
    За помощью в решении этого вопроса Вы можете обратиться к нашим партнёрам с Marketplace: http://timeweb.com/ru/community/marketplace»

    «Здравствуйте.

    Переключил Вам версию PHP на 5.4, на данный момент Ваш сайт отображается корректно. Для проверки необходимо сбросить кэш браузера и воспользоваться режимом инкогнито.

    В дальнейшем, Вы можете производить смену версии PHP самостоятельно, более подробная информация доступна в нашем справочном центре:
    timeweb.com/ru/help/pages/viewpage.action?pageId=4358256

    Если у Вас будут дополнительные вопросы, обращайтесь, пожалуйста.»

    Как это посмотреть, то что вы мне описали » в логе ошибок сервера (PHP)»? Это я на будущее спрашиваю, я пока в этом ничего не понимаю.

    Модератор Yui

    (@fierevere)

    ゆい

    то , что в логах вам поддержка написала
    на настоящее время вам больше ничего делать не нужно

    ок. Спасибо! ))

    Модератор Yui

    (@fierevere)

    ゆい

    тем не менее, многие плагины сейчас требуют 5.5 или выше, например Yoast SEO

    https://timeweb.com/ru/help/pages/viewpage.action?pageId=4358256

    попробуйте по инструкции хостинга (см первый параграф, где картинка) поставить версию PHP 7.1
    если что-то пойдет не так — вернете 5.4

    ок, спасибо!

Просмотр 6 ответов — с 1 по 6 (всего 6)
  • Тема «Исчез Elementor» закрыта для новых ответов.