Поддержка WooCommerce Как обновить Woocommerce не до последней версии?

  • Подскажите, плиз, как можно обновить woocommerce до версии 3.5.0, а не до последней 4.2. Потому что почти все мои плагины не поддерживают последнюю версию WC, очень много надо будет переделывать. А нужна только интеграция с Фейсбук, для этого достаточно и 3.5.0.

Просмотр 7 ответов — с 1 по 7 (всего 7)
  • Модератор Denis Yanchevskiy

    (@denisco)

    WordPress-разработчик, wpcute.ru

    Скачать нужную версию на странице плагина. Раздел «Предыдущие версии».

    И загрузить содержимое по FTP или через панель управления хостингом.

    Нужную мне версию WC я уже давно скачал. Не понимаю, как безопасно подменить одну версию WC другой. Можно конечно просто «грохнуть» старую версию и поставить скаченную, но жалко все данные базы клиентов, которые хранятся в старой.

    Так БД трогать и не надо. Удаляйте только файлы плагина.

    Модератор Denis Yanchevskiy

    (@denisco)

    WordPress-разработчик, wpcute.ru

    Можно удалить текущую папку плагина и загрузить новую или попробовать загрузить файлы поверх текущей. База клиентов хранится в базе данных сайта, её удалить не нужно.

    Подскажите, плиз, правильный следующий шаг.

    Я деактивировал старую версию WC, переименовал ее в хостинге в WooCommerce Old, затем скачал и установил нужную мне версию 3.5.0. и активировал ее. Все работает. В итоге у меня сейчас в админке сайта две версии WC — старая 3.2.1. неактивная и новая 3.5.0 активная. Однако те данные, которые меня очень интересуют, а именно уже сделанные клиентами заказы, я вижу только в старой версии WC в отчетах. Да, сама база зарегистрировавшихся клиентов есть и в пользователях, но там нет данных о сделанных ими заказах. Есть какой-то способ перекинуть данные из старой версии в новую? Или если я сейчас вообще «грохну» старую версию, они сами «подцепятся» к новой? Или потеряются совсем?
    В любом случае всем огромное спасибо за помощь!

    Ребята, вопрос снимается! По дурости случайно запустил обновление WC до последней версии 4.2.2. и , о чудо, все плагины, про которые писалось, что они «не тестированы» с новой версией почему-то все равно работают!! Наверно, мне просто повезло!

Просмотр 7 ответов — с 1 по 7 (всего 7)