Поддержка Проблемы и решения Этот блок имеет неверное содержимое: WP 5 воспринимает как ошибку тэг colspan

  • После обновления на WordPress 5 (сейчас стоит 5.1.1) начались сплошные проблемы с таблицами: готовые таблицы (с англоязычных ресурсов, которые я перевожу) в режиме редактирования HTML либо не вставляются, либо не редактируются — в обоих случаях ругается на недопустимое содержимое. Раньше такие проблемы никогда не возникали. А когда я делаю копи-паст таблицы в режиме просмотра, то всегда теряется объединение ячеек. Собственно когда я добавляю это объединение (colspan="2"), то тогда и ругается на недопустимое содержимое.

    Это как-нибудь можно исправить? Или может есть удобные плагины для редактирования таблиц (объединения ячеек) непосредственно в блоках записи?

    • Тема изменена 1 год, 1 месяц назад пользователем Ar1ur.
    • Тема изменена 1 год, 1 месяц назад пользователем Ar1ur.
    • Тема изменена 1 год, 1 месяц назад пользователем Ar1ur.
Просмотр 6 ответов — с 1 по 6 (всего 6)
  • Вот пример неправильного, по мнению WP 5, кода HTML:

    <table>
    <tbody>
    <tr>
    <td>Заголовок 1</td>
    <td>Заголовок 2</td>
    <td>Заголовок 3</td>
    </tr>
    <tr>
    <td colspan=»2″>Текст 1</td>
    <td>Текст 2</td>
    </tr>
    <tr>
    <td>Текст 3</td>
    <td>Текст 4</td>
    <td>Текст 5</td>
    </tr>
    </tbody>
    </table>

    отключите гутенберг для редактирования таблиц.

    Модератор Yui

    (@fierevere)

    ゆい

    наверное не обязательно отключать гутен,
    можно попробовать классический блок при установленном classic editor
    или классический параграф, при наличии еще и tinymce advanced

    Гутенберг — это какой-то плагин? Вроде нет такого. Использование классического блока действительно помогает.

    Модератор Yui

    (@fierevere)

    ゆい

    Гутенберг — штатный редактор начиная с WP 5.0 пришедший на замену TinyMCE,
    «отключается» установкой Classic Editor и установкой в настройках предпочитаемого редактора как классический редактор

    Спасибо!

Просмотр 6 ответов — с 1 по 6 (всего 6)
  • Тема «Этот блок имеет неверное содержимое: WP 5 воспринимает как ошибку тэг colspan» закрыта для новых ответов.