• Добавил модул All in One SEO в ВП. В записях добавились дополнительные поля для СИО, но когда я в них добавляю данные, они не отображаються в сайте. Кто готов помочь и за сколько ?

    Писать на ICQ 8-009-288
    smska4u@gmail.com

Просмотр 9 ответов — с 1 по 9 (всего 9)
  • Они и не должны отображаться.
    Текст, который вы там вводите, виден только поисковым ботам (в исходном коде загруженных страниц он есть).

    Здравствуйте !

    Опишу проблему подробней.

    Description и keywords выходят пустые но функция wp_head(); вызывается.
    Версия ВП 2.9.1 плагин установлен нормально. Есть возможность заполнять данные description и keywords.

    Вот код header.php:

    <head>

    <title><?php bloginfo(‘name’); ?><?php wp_title(); ?></title>
    <meta http-equiv=»Content-Type» content=»text/html; charset=<?php bloginfo(‘charset’); ?>» />
    <meta name=»description» content=»» />
    <meta name=»keywords» content=»» />

    <style type=»text/css» media=»screen»>
    @import url( <?php bloginfo(‘stylesheet_url’); ?> );
    </style>
    <meta name=»robots» content=»index,follow» />

    <link rel=»alternate» type=»application/rss+xml» title=»RSS 2.0″ href=»<?php bloginfo(‘rss2_url’); ?>» />
    <link rel=»alternate» type=»text/xml» title=»RSS .92″ href=»<?php bloginfo(‘rss_url’); ?>» />
    <link rel=»alternate» type=»application/atom+xml» title=»Atom 0.3″ href=»<?php bloginfo(‘atom_url’); ?>» />
    <link rel=»pingback» href=»<?php bloginfo(‘pingback_url’); ?>» />
    <?php wp_get_archives(‘type=monthly&format=link’); ?>
    <?php //comments_popup_script(); // off by default ?>
    <?php wp_head(); ?>
    </head>

    И вот код станицы после обработки.

    <head>

    <title>Рак как психосоматоз | medic — Part 2</title>
    <meta http-equiv=»Content-Type» content=»text/html; charset=UTF-8″ />
    <meta name=»description» content=»» />
    <meta name=»keywords» content=»» />

    <style type=»text/css» media=»screen»>
    @import url( http://localhost/wordpress_ru/wp-content/themes/health/style.css );
    </style>
    <meta name=»robots» content=»index,follow» />

    <link rel=»alternate» type=»application/rss+xml» title=»RSS 2.0″ href=»http://localhost/wordpress_ru/?feed=rss2&#8243; />
    <link rel=»alternate» type=»text/xml» title=»RSS .92″ href=»http://localhost/wordpress_ru/?feed=rss&#187; />
    <link rel=»alternate» type=»application/atom+xml» title=»Atom 0.3″ href=»http://localhost/wordpress_ru/?feed=atom&#187; />
    <link rel=»pingback» href=»http://localhost/wordpress_ru/xmlrpc.php&#187; />
    <link rel=’archives’ title=’Февраль 2010′ href=’http://localhost/wordpress_ru/?m=201002&#8242; />
    <link rel=»alternate» type=»application/rss+xml» title=»medic » Рак как психосоматоз Category Feed» href=»http://localhost/wordpress_ru/?feed=rss2&cat=1&#8243; />
    <link rel=’stylesheet’ id=’wp-pagenavi-css’ href=’http://localhost/wordpress_ru/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.60&#8242; type=’text/css’ media=’all’ />
    <link rel=»EditURI» type=»application/rsd+xml» title=»RSD» href=»http://localhost/wordpress_ru/xmlrpc.php?rsd&#187; />
    <link rel=»wlwmanifest» type=»application/wlwmanifest+xml» href=»http://localhost/wordpress_ru/wp-includes/wlwmanifest.xml&#187; />
    <link rel=’index’ title=’medic’ href=’http://localhost/wordpress_ru&#8217; />
    <meta name=»generator» content=»WordPress 2.9.1″ />

    <!— All in One SEO Pack 1.6.10 by Michael Torbert of Semper Fi Web Design[178,237] —>
    <meta name=»robots» content=»noindex,follow» />
    <link rel=»canonical» href=»http://localhost/wordpress_ru/?cat=1/page/2/&#187; />
    <!— /all in one seo pack —>
    </head>

    Из кода видно что плагин вызывается, но странно почему поля description и keywords пустые ?
    Помогите разобраться пожалуйста.

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Возможно, потому что они уже прописаны пустыми в header.php. Зачем?

    Без них тоже не добавляются.

    Вот код:

    <head>

    <title><?php bloginfo(‘name’); ?><?php wp_title(); ?></title>
    <meta http-equiv=»Content-Type» content=»text/html; charset=<?php bloginfo(‘charset’); ?>» />

    <style type=»text/css» media=»screen»>
    @import url( <?php bloginfo(‘stylesheet_url’); ?> );
    </style>
    <meta name=»robots» content=»index,follow» />

    <link rel=»alternate» type=»application/rss+xml» title=»RSS 2.0″ href=»<?php bloginfo(‘rss2_url’); ?>» />
    <link rel=»alternate» type=»text/xml» title=»RSS .92″ href=»<?php bloginfo(‘rss_url’); ?>» />
    <link rel=»alternate» type=»application/atom+xml» title=»Atom 0.3″ href=»<?php bloginfo(‘atom_url’); ?>» />
    <link rel=»pingback» href=»<?php bloginfo(‘pingback_url’); ?>» />
    <?php wp_get_archives(‘type=monthly&format=link’); ?>
    <?php //comments_popup_script(); // off by default ?>
    <?php wp_head(); ?>
    </head>

    И код после обработки скрипта:

    <head>

    <title>Рак как психосоматоз | medic</title>
    <meta http-equiv=»Content-Type» content=»text/html; charset=UTF-8″ />

    <style type=»text/css» media=»screen»>
    @import url( http://localhost/wordpress_ru/wp-content/themes/health/style.css );
    </style>
    <meta name=»robots» content=»index,follow» />

    <link rel=»alternate» type=»application/rss+xml» title=»RSS 2.0″ href=»http://localhost/wordpress_ru/?feed=rss2&#8243; />
    <link rel=»alternate» type=»text/xml» title=»RSS .92″ href=»http://localhost/wordpress_ru/?feed=rss&#187; />
    <link rel=»alternate» type=»application/atom+xml» title=»Atom 0.3″ href=»http://localhost/wordpress_ru/?feed=atom&#187; />
    <link rel=»pingback» href=»http://localhost/wordpress_ru/xmlrpc.php&#187; />
    <link rel=’archives’ title=’Февраль 2010′ href=’http://localhost/wordpress_ru/?m=201002&#8242; />
    <link rel=»alternate» type=»application/rss+xml» title=»medic » Рак как психосоматоз Category Feed» href=»http://localhost/wordpress_ru/?feed=rss2&cat=1&#8243; />
    <link rel=’stylesheet’ id=’wp-pagenavi-css’ href=’http://localhost/wordpress_ru/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.60&#8242; type=’text/css’ media=’all’ />
    <link rel=»EditURI» type=»application/rsd+xml» title=»RSD» href=»http://localhost/wordpress_ru/xmlrpc.php?rsd&#187; />
    <link rel=»wlwmanifest» type=»application/wlwmanifest+xml» href=»http://localhost/wordpress_ru/wp-includes/wlwmanifest.xml&#187; />
    <link rel=’index’ title=’medic’ href=’http://localhost/wordpress_ru&#8217; />
    <meta name=»generator» content=»WordPress 2.9.1″ />

    <!— All in One SEO Pack 1.6.10 by Michael Torbert of Semper Fi Web Design[178,237] —>
    <meta name=»robots» content=»noindex,follow» />
    <link rel=»canonical» href=»http://localhost/wordpress_ru/?cat=1&#8243; />
    <!— /all in one seo pack —>
    </head>

    Убирал ставил title и тоже не помогает (.

    Спасибо всем за внимание к моей проблеме.

    Что стоит в настройках плагина (/wp-admin/options-general.php?page=all-in-one-seo-pack/aioseop.class.php)?
    Обратите внимание на: Use Categories for META keywords, Use Tags for META keywords, Dynamically Generate Keywords for Posts Page и Autogenerate Descriptions.

    Plugin Status: enabled

    И галочками отметил все опции.

    Use Categories for META keywords, Use Tags for META keywords, Dynamically Generate Keywords for Posts Page и Autogenerate Descriptions.

    Keywords и Descriptions вообще не фигурируют, после обработки кода.

    А на дефолтной теме работает?
    Если да, то может в вашей теме в functions.php какой хак используется?
    Если нет, то отключите все другие плагины.
    Возможно есть Simple Tags, который тоже настроен на раздачу META тегов?

    Simple Tags отключает добавление meta, если установлен AIOSEO
    Проверьте на стандартном шаблоне

    Обновите плагин, была подобная проблема…

Просмотр 9 ответов — с 1 по 9 (всего 9)
  • Тема «Настройка All in One SEO , помогите за вознаграждение» закрыта для новых ответов.