Поддержка Проблемы и решения Нет поля ACF после цикла get_posts или wp_query?

  • Почему так происходит я не понимаю, я сбрасывал с помощью wp_reset_postdata() и wp rest qurey, все равно нет вывода, я перерыл уже пол интернета и не понимаю в чем проблема.
    Это блок кода после которого ниче не выводится.

    <?php
          $posts = get_posts( array(
            'numberposts' => 1,
            'post_type'   => 'blog-post',
          ) );
          
          foreach( $posts as $post ){
           
           ?>
          <div class="picture-blog">
            <?php the_post_thumbnail(); ?>
          </div>
          <div class="text-blog col">
            <h4 class="title-blog">
              <?php the_title(); ?>
            </h4>
            <p class="date">
              <?php the_date() ?>
            
    
            <div class="desc">
              <?php the_excerpt(); ?>
            </div>
            <div class="btn btn-blog-more">
              <a href="<?php the_permalink(); ?>">
                Подробнее
              </a>
            </div>
            <div class="btn btn-blog-all">
              <a href="<?php the_permalink(87); ?>">
                Читать все статьи
              </a>
            </div>
          </div>
          <?php
          }
          
    
          wp_reset_postdata(); // сброс
              ?>

    Это сам вывод.

    <section class="container content">
      <h3 class="main-title">
        Остались вопросы?
      </h3>
      <div class="faq-wrapper">
        <div class="faq-col col">
          <?php if( have_rows('faq' ) ): ?>
    
          <?php while ( have_rows('faq') ) : the_row(); ?>
          <div class="faq-item">
            <div class="faq-title">
              <?= the_sub_field('question');?>
            </div>
            <div class="faq-content">
              <?= the_sub_field('answer');?>
            </div>
          </div>
          <?php endwhile; ?>
          <?php endif; ?>
        </div>
        <div class="picture">
          <img src="<?php bloginfo('template_url')?>/images/dest/faq.png" alt="">
        </div>
    
      </div>
    </section>
    

    Это лишь пример вывода, на деле не выводится ничего, кроме вывода со страницы опций