Поддержка Проблемы и решения Не включается TinyMCE

  • Здравствуйте!
    У меня не появляется редактор TinyMCE Advanced. Плагин установлен, активирован. С другими конфликт вряд ли возможен, потому что, помимо предустановленных самим вордпрессом, я активировала только TinyMCE и YaMaps (собственно, мне не столько нужен TinyMCE, сколько кнопка для установки YaMaps — если можете подсказать, как установить Яндекс.карту другим способом, то за любой совет спасибо).
    В какой-то момент (я экспериментировала с разными плагинами для установки карт) у меня появился редактор TinyMCE. Я видела и кнопку для YaMaps. Но я не поняла, как эти панель появилась и куда она исчезла.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 15 ответов — с 1 по 15 (всего 20)
  • Модератор SeVlad

    (@sevlad)

    wp.me/3YHjQ

    Какая версия ВП?

    Для использования Яндекс карт вообще не обязательно плагин устанавливать. Я создаю в конструкторе Яндекса карту и вставляю предложенный код в режиме HTML в классическом редакторе или в блоке HTML нового блочного редактора.

    создаю в конструкторе Яндекса карту и вставляю предложенный код в режиме HTML в классическом редакторе или в блоке HTML нового блочного редактора.

    А чтобы код карты случайно не сломать при последующих редактированиях данного поста (страницы) или при частой вставке этого кода в другие места, его можно нужно преобразовать в шорткод.
    ( и это касается не только скриптов\кодов карт Яндекса)
    С чем прекрасно справляется плагин https://ru.wordpress.org/plugins/insert-html-snippet/

    P.S. А открытия https://putevoditel-dlya-gurmanov.000webhostapp.com я так и не дождался…. Или сайт на бесплатном хостинге?

    • Ответ изменён 1 год, 1 месяц назад пользователем O.
    • Ответ изменён 1 год, 1 месяц назад пользователем O.

    В гутенберге, кстати, при использовании блока HTML-код ничего не ломается 😉

    P.S. вчера тоже не дождался загрузки страницы

    Модератор SeVlad

    (@sevlad)

    wp.me/3YHjQ

    Или сайт на бесплатном хостинге?

    Ну так да.

    ПОЧТИ ОФТОП

    В гутенберге, кстати, при использовании блока HTML-код ничего не ломается

    Зато в этом Гутенберге (после ночного обновления WP до 5.0, так и хочется сказать «гутенморген» 🙂 ) ломается главное — привычная ежедневная рутинная работа по созданию постов. Тому кто впервые познакомился с WP он может и нравится и у них есть время на его освоение. А для тех кто ежедневно и не первый год работает с сайтом по заполнению его контентом — это тот самый случай, когда лучшее — враг хорошего.

    • Ответ изменён 1 год, 1 месяц назад пользователем O.
    Модератор Юрий

    (@yube)

    Spectrum, простите за вопрос, Вы до сих пор работаете в MS-DOS или уже перешли на windows 3.1? 🙂

    А для тех кто ежедневно и не первый год работает с сайтом

    …прям на главной страницы после обновления написано: «Не нравится новый редактор? установите классический!» И большая ссылка на него

    [oftop]

    Вы до сих пор работаете в MS-DOS или уже перешли на windows 3.1?

    "... Одним из примеров громоздкой и, по мнению авторов,
    бесполезной надстройки является интегрированная система
    WINDOWS фирмы Microsoft. Эта система занимает почти 1 Мбайт
    дисковой памяти и рассчитана на преимущественное использование
    совместно с устройством типа "мышь"
    ...
    Таким образом, читатель уже понял, что среди надстроек над ДОС
    бывают довольно бесполезные системы, которые только выглядят
    красиво, а на самом деле отнимают время пользователя, память
    на дисках и оперативную память ЭВМ. Обманчивая красота таких
    систем, однако, сильно воздействует на неискушенных
    пользователей, которые не имели практики работы на машине.
    Инерция мышления бывает столь сильна, что авторам приходилось
    наблюдать, как люди, начавшие работать с подобной надстройкой,
    впоследствии с трудом заставляют себя изучать команды ДОС.
    Хочется предостеречь от этой ошибки читателей ..."

    Из книги: »Персональные ЭВМ в инженерной практике», М. Радио и связь, 1989.
    [/oftop]

    установите классический!

    Все это я изучил и освоил еще до обновления 5.0, когда Гутенморген был еще плагином. Так что лично я был готов к «сюрпризу»

    Вы до сих пор работаете в MS-DOS или уже перешли на windows 3.1

    Я понял подковырку. Естественно рано или поздно я тоже перейду к Гутенбергу, тем более я никогда не отказываюсь от новшеств и обновлений. Но сейчас просто не до этого. В данный момент мне надо работать, а не экспериментировать с новым редактором и разбираться/бороться с его говнотерками.

    Модератор Юрий

    (@yube)

    Я понял подковырку.

    Ни на секунду не сомневался 😉

    Спасибо всем, что не прошли мимо и попробовали помочь!
    Да, сайт на бесплатном хостинге, поэтому не удивляюсь, если кто-то не смог зайти. Хотя я до сих пор (и прямо вот только что) заходила без проблем. Но, возможно, мне просто везло.
    Код с самих Яндекс.карт мне не поможет, потому что он позволяет встроить только конкретную карту с уже встроенной отметкой — и ничего больше. А мне надо сделать так, чтобы на карте было несколько отметок, и чтобы на них можно было кликнуть (чтобы были на них описания мест) — и попасть на статью об этом месте. Т.е. чтобы была метка-ссылка.
    Так что вопрос с Tiny актуален. Гуттерберг у меня вообще никак не пошел — тоже пыталась установить.

    Зачем вам помогать, если вы проходите мимо конкретной помощи именно по этой проблеме?

    чтобы на карте было несколько отметок, и чтобы на них можно было кликнуть (чтобы были на них описания мест) — и попасть на статью об этом месте. Т.е. чтобы была метка-ссылка.

    Хорошо. Сделаю еще одну попытку:

    Полно плагинов именно с такой возможностью. Вам только понадобится время и терпение чтобы найти, то что вам подойдет наиболее всего, протестировать и настроить этот плагин. Подбираем плагин тут:

    https://ru.wordpress.org/plugins/search/maps/

    • Ответ изменён 1 год, 1 месяц назад пользователем O.

    Spectrum, а с чего вы взяли, что я прошла мимо вашей ссылки? Я нашла там кучу плагинов, закачала, но ни один из них не включает карту, увы. Точнее, один включил, но карта не та, что мне надо. А та, что надо, — требует TinyMCE, поэтому я здесь с вопросом про Tiny. А вы вместо помощи по Tiny даете мне информацию, которую уже давали.
    Конечно, возможно, проблема в том, что я пользуюсь бесплатным хостингом. Возможно, там куча ограничений. Но тут, увы, у меня нет вариантов: в платный никто не будет вкладываться. Не тот проект.

    Если у Вас версия вордпресса 5.0.1 тогда у нее может не работать плагин TinyMCE Advanced

Просмотр 15 ответов — с 1 по 15 (всего 20)
  • Тема «Не включается TinyMCE» закрыта для новых ответов.