Поддержка WordPress Multisite не грузятся стили у новых юзеров

  • Здравствуйте,

    помогите с такой проблемой.
    установила wpRU 3.0, подключила сеть, зарегистрировалась новым пользователем, и создала блог. Все заработало, но, стили не загружается.
    в заголове путь до файла css прописан, но физически его на сервере нет.
    возможно, rewrite как-то не срабатывает?
    вот этот для примера создан
    http://proznanie.ru/blog/xxxx/

    пробовала ставить английскую версию — история та же.
    подскажите, пожалуйста, куда копать?

Просмотр 10 ответов — с 1 по 10 (всего 10)
  • Проверьте внимательно права на папки, может в правах дело. Так же, может у вас есть возможность посмотреть логи ошибок сервера, там все понятней будет.

    логи смотреть могу, но странно, что записи появляются не в «ошибках», а в «доступе»
    109.194.44.192 — — [27/Jul/2010:02:06:02 +0000] «GET /blog/xxxx/wp-content/themes/twentyten/style.css HTTP/1.1» 404 162 «http://proznanie.ru/blog/xxxx/» «Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)»
    109.194.44.192 — — [27/Jul/2010:02:06:02 +0000] «GET /blog/xxxx/wp-content/themes/twentyten/images/headers/path.jpg HTTP/1.1» 404 162 «http://proznanie.ru/blog/xxxx/» «Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)»

    поставила уже 777 на blogs.dir и на wp-content (сначала стояли 666)

    и как-то слабо помогает(

    .htaccess в порядке?

    при установке сети в админке сгенерировлся текст htaccess,
    скопировала в файл, и загрузила на сайт. должен быть в порядке

    Вы не могли бы посмотреть, как будет вести себя блог, если на него повесить другой шаблон?

    Да, это первое, что я стала делать.
    результат нулевой — на основном блоге все грузится, на дочернем — ничего.
    темы активированы.

    А у вас nginx, может действительно с реврайтами беда.
    http://developersmind.com/2010/05/17/enable-multi-site-in-wordpress-3-0/

    похоже… спасибо, буду в этом направлении копать.

    Та же ситуация — для новых пользователей стили не загружаются.
    WP 3.0.1 мультисайт. Апачи.

    Сам WordPress располагается в папке /blogs/
    Путь к блогам такой:
    blogs.narod-market.ru/xxx/

    .htaccess такой:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ — [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ — [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Что может быть не так?

    Проблема разрешилась.
    Обратился к системным администраторам, дал им почитать readme и они настроили Apache как надо.
    Теперь стили грузятся 🙂

Просмотр 10 ответов — с 1 по 10 (всего 10)
  • Тема «не грузятся стили у новых юзеров» закрыта для новых ответов.