• Здравствуйте!

    Обнаружил, что виджет «Облако меток» не выводит статьи имеющие данную метку.
    Если в настройках виджета «Таксономия» установить — «Рубрики» — то всё работает правильно.
    Если «Таксономия» установить «Метки», то просто заново выводится главная страница Блога.
    Хотя проверил все метки — всё заполнено правильно. URL каждой метки тоже формируется правильно. Например: ezdiumno.ru/metka_/gps.

    В чём может быть проблема?
    (В Поиске искал, читал. Но ответа не нашел.)

    Буду благодарен за помощь!

    • Тема изменена 6 лет, 3 месяца назад пользователем ezdiumno_ru.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 13 ответов — с 1 по 13 (всего 13)
  • /metka_/

    А это вообще откуда такое взялось?

    Модератор Юрій

    (@yube)

    По-моему, метки (если это метки) и без облака не работают. Могу предположить наличие косяков в шаблонах, следовательно, посоветовать проверить на любой нормальной, т.е. идущей в комплекте с WP, Темой. А также пересохранить настройки постоянных ссылок.

    Когда настраивал WP в «Консоль — Настройки — Постоянные ссылки — Дополнительно — Префикс для меток» поставил. А что, не надо было?

    Но ведь там же, в «Префикс для рубрик» я поставил rub_ и виджет «Облако меток» с рубриками работает как надо.

    Если не надо было, то что там нужно поставить? Или вообще поле «Префикс для меток» оставить пустым?

    Или вообще поле «Префикс для меток» оставить пустым?

    Совершенно верно!

    А что, не надо было?

    Меня смущает в первую очередь подчёркивание.
    Попробуйте убрать.

    Юрию!

    Кстати да, в пункте метки в каждой статье если кликнуть по метке — история такая же как с облаком. Просто перезагружает главную страницу.

    Очень может быть, что виноват Шаблон. Вроде выбирал достаточно проверенный, но всякое может быть.

    Может подскажете, где глянуть? Может что-то поредактировать в «Консоль — Внешний вид — Редактор»?

    (Уж очень не хочется убирать Облако меток. Ну а замена шаблона вообще исключается!)

    • Ответ изменён 6 лет, 3 месяца назад пользователем ezdiumno_ru.

    SeVlad

    Вообще говоря, посмотрел другой сайт — там эти поля вообще пустые…
    Попробую сейчас всё из поля удалить.

    • Ответ изменён 6 лет, 3 месяца назад пользователем ezdiumno_ru.

    виноват Шаблон. Вроде выбирал достаточно проверенный

    Не шаблон, а тема. И выбирали вы его наверное на на какой-либо помойке. Потому что в WP устанавливают темы и устанавливают их вот отсюда, где они в самом деле достаточно проверенные https://ru.wordpress.org/themes/

    • Ответ изменён 6 лет, 3 месяца назад пользователем O.

    Perdyllo

    А вот: «Консоль — Внешний вид — Темы» — тоже помойка?

    Кстати, в указанной вами ссылке этот шаблон тоже есть.
    То есть вы дали ссылку тоже на помойку?

    • Ответ изменён 6 лет, 3 месяца назад пользователем ezdiumno_ru.

    Вообщето начинать надо с указания адреса сайта, которому нужна помощь.

    Внешний вид — Темы

    Вот и называйте вещи своими именами.

    Perdyllo

    А вам мой ник ни о чем не говорит???
    Да и в топике, если вы потрудились дочитать его до конца, есть адрес сайта: ezdiumno.ru

    вами ссылке этот шаблон тоже есть.

    В указанной мной ссылке есть темы. А шаблоны есть только на помойках
    если между словами тема и шаблон вы ошибочно ставите знак равенства.
    https://codex.wordpress.org/ЧАВО/Терминология

    SeVlad

    Убрал подчеркивание — всё осталось по прежнему.
    Оставил поле вообще пустым — всё по прежнему — не работает как надо.

    • Ответ изменён 6 лет, 3 месяца назад пользователем ezdiumno_ru.
Просмотр 13 ответов — с 1 по 13 (всего 13)
  • Тема «Не работает как надо виджет «Облако меток»» закрыта для новых ответов.