• Доброго времени суток!
    Прошу помощи.
    сайт http://www.al-craft.info/
    После выполнения всех пунктов, указанных в Как задавать правильные вопросы остались те же проблемы, а значит без вас мне ни как.
    Суть вопроса
    Использую WordPress 4.7.1, установлены плагины Supsystic (галерея, кнопки соц сетей, лайтбокс), Yoast SEO, Lingotek Translation. Все версии последние.
    После обновления вордпресса и плагинов перестала настраиваться и тема и плагины работать, некоторые (Yoast SEO) и настраиваться перестали.
    Пробовал отключить все плагины и установить тему по умолчанию — не дало результата.
    Похожая проблема уже возникала при предыдущем обновлении и тогда служба поддержки supsystic.com дала ответ, что их плагин конфликтовал с Lingotek. Сейчас же не работают и другие плагины.
    Подскажите пожалуйста как выйти из ситуации?

    • Тема изменена 7 лет, 6 месяцев назад пользователем alzabolotnyi.
Просмотр 15 ответов — с 1 по 15 (всего 17)
  • Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    перестала настраиваться и тема и плагины работать

    В чём это выражается?

    некоторые (Yoast SEO) и настраиваться перестали.

    А это?

    Когда выбираю Внешний вид -> Настроить — появляется только крестик «закрыть», а остальные пункты вообще не появляются.
    скрин настройки темы
    При переходе на вкладку Yoast SEO -> «Dashboard» так же не видно никаких настроек, а видны только закладки для перехода по настройкам.
    скрин для YOAST SEO

    а остальные пункты вообще не появляются.

    Смотрите ошибки http://codex.wordpress.org/%D0%A7%D0%90%D0%92%D0%9E/%D0%91%D0%B5%D0%BB%D1%8B%D0%B9_%D1%8D%D0%BA%D1%80%D0%B0%D0%BD

    ЗЫ. Скрина в посте нет. Если хотите что-то показать для всех — заливайте картинки на нормальные имж-сервисы (http://imgur.com напр), никак неограничивающие пользователя для просмотра картинок. (По ЮА и тем более требующие авторизацию)

    • Ответ изменён 7 лет, 6 месяцев назад пользователем SeVlad.
    • Ответ изменён 7 лет, 6 месяцев назад пользователем SeVlad.

    исправляюсь.
    скрин настройки темы:
    скрин настройки темы

    и скрин YOAST SEO:
    скрин YOAST SEO

    • Ответ изменён 7 лет, 6 месяцев назад пользователем SeVlad. Причина: картинки

    log, при настройке темы выдает такой:
    log сайта

    а вот что с этим делать, — тут бааааааааальшой вопрос… я не знаю…

    • Ответ изменён 7 лет, 6 месяцев назад пользователем SeVlad.

    499 статус — прерывание nginx пользователем до того как он ответил или загрузил

    продолжим гуглить дальше

    исправляюсь

    Шикарно 🙂

    Вы не видите что постите?
    Ок, я исправил, но логи и пр ошибки нужно показывать текстом (если решили показать).

    Ида, это не те логи. Нужно смотреть логи ошибок, а не доступа

    • Ответ изменён 7 лет, 6 месяцев назад пользователем SeVlad.

    Действительно, я не видел тех картинок, что Вы исправили, но при нажатии кнопки img мне был выдан запрос на вставку Урл и альт, что я и сделал. Других указаний не было. По крайней мере в глаза не попадало… В результате был текст с хтмл тегом на рисунок… Что я сделал не так? На будущее чтобы делал так. Спасибо.

    [офтоп]

    Что я сделал не так? На будущее чтобы делал так.

    Вставлять надо адрес КАРТИНКИ, а не СТРАНИЦЫ. С расширением файла. Выглядит он сейчас так: http://i.imgur.com/ZecXKxh.png

    Рекомендую использовать программку https://getsharex.com/. Там и скриншотер и простой редактор и заливка на множество разных серверов (и не только в картинкосервисы, но и код-, и в соцсети постит) и много др. приятных полезностей. При этом он лёгкая и бесплатная.

    [/офтоп]

    • Ответ изменён 7 лет, 6 месяцев назад пользователем SeVlad.

    благодарю

    На моем сайте точно такие же проблемы. Пока не хочу откатывать назад. Очень надеюсь, что решение проблемы найдут.

    В настройках плагина только заголовки

    В настройках темы тоже

    • Ответ изменён 7 лет, 6 месяцев назад пользователем ykrkozak.

    ищу файл *.log по всему сайту

    [20-Jan-2017 12:10:22 UTC] PHP Notice: Undefined index: gallery_id in /home/alcraft/al-craft.info/www/wp-content/plugins/gallery-by-supsystic/src/GridGallery/Galleries/Model/widget.php on line 69

    соответственно лезу туда… и плагина-производителю напишу

    дальше, конечно, уже сложнее:

    (67)<select id=»<?php echo $this->get_field_id( ‘gallery_id’ ); ?>» class=»widefat» name=»<?php echo $this->get_field_name( ‘gallery_id’ ); ?>» type=»text»>
    (68) <?php foreach($id as $element)
    (69) if($instance[‘gallery_id’] == $element[‘value’]) {
    (70) echo «<option value=» . $element[‘value’] . » selected>». $element[‘name’] . «</option>»;
    (71) } else {
    (72) echo «<option value=» . $element[‘value’] . «>». $element[‘name’] . «</option>»;
    }
    ?>
    </select>
    в чем тут проблема может быть? в каком нибудь ID?

    @ykrkozak, Правила форума, п2.

    ищу файл *.log по всему сайту

    Не надо искать по всему. Надо узнать у хостера.
    Или вывести на экран.
    Или прописать в конфиге

    define( 'WP_DEBUG', true ); // Or false
    if ( WP_DEBUG ) {
        define( 'WP_DEBUG_LOG', true );
        define( 'WP_DEBUG_DISPLAY', false );
    }

    и debug.log появится в wp-content

Просмотр 15 ответов — с 1 по 15 (всего 17)
  • Тема «Не работает настройка темы, плагины Supsystic, Yoast SEO» закрыта для новых ответов.