Поддержка Проблемы и решения Обновление до 4.6

  • Решено azatka

    (@azatka)


    Обновился до версии 4.6 и сразу появилась ошибка 502. Хостинг ни при чем, другие сайты работают, на которых не обновлялся. Пробую менять на старые файлы (копии старых сохраняю). Беда полная. Если удастся восстановить, больше никогда не приму обновления!

Просмотр 13 ответов — с 1 по 13 (всего 13)
  • Модератор Yui

    (@fierevere)

    ゆい

    с какой версии обновляли?

    502 — ошибка бэкенда, лучше всего с этим обращаться в поддержку хостинга или хотя бы просмотреть логи

    С предпоследней версии 4.5.3

    Модератор Yui

    (@fierevere)

    ゆい

    там маленький сет обновлений sql, так что навряд ли это явилось причиной

    логи/поддержка хостинга, потому что у меня нет предположений где так зависли скрипты что выдается 502, а может просто так повезло что хостинг перегружен и на нем возникли проблемы в момент обновления

    У меня на этом хостинге еще сайты есть, они работают. Обычно, при ошибках хостинга, все не работали

    Всем привет!
    Только что обновил два сайта до версии WP 4.6
    Обновление прошло успешно — оба работают (хостинг один)…

    Может, зайти по FTP и удалить папки с плагинами, по одной лучше. Если заработает, то будет ясна причина

    Вы полагаете, какой-то плагин несовместим с новой версией?

    Всем спасибо за ответы. Проблема решена. Поддержка хостинга ответила, что Вордпресс не поддерживает PHP 5.3, которая у меня была установлена, изменили версию до 5.5 (не пойму, как до этого поддерживал)

    Модератор Yui

    (@fierevere)

    ゆい

    минимальные требования wordpress не менялись, по прежнему php 5.2.4
    для плагинов и тем требования повышаются, но это уже на совести авторов плагинов и тем

    также 502 ошибка не типична в случае несовместимости версий PHP, будет 500

    разве что имеет место какая-то иная проблема, которая заставляет интерпретатор виснуть

    http://php.net/supported-versions.php
    тем не менее любая поддержка PHP 5.3 закончена 2 года назад и многие обновляют, вследствие чего новые релизы, в том числе и WordPress получают мало тестирования на устаревших неподдерживаемых версиях, вполне может что-то и вылезти

    изменили версию до 5.5

    это правильное решение. Можно и выше )

    Спасибо за уделенное время и грамотные ответы!

    Добрый! На счет версии PHP 5.6 — у меня тоже ошибка 502.
    Сейчас буду пробовать на 5.5

    Проблема не только в PHP!!! А и в памяти выделяемой хостером, по умолчанию у меня 64М.
    Проблема была с файлом wp-admin/includes/media.php он ждал больше 67М.
    Мне пришлось увеличить до 128M и проблема решена.
    Всё запустилось!

    Модератор Yui

    (@fierevere)

    ゆい

Просмотр 13 ответов — с 1 по 13 (всего 13)
  • Тема «Обновление до 4.6» закрыта для новых ответов.