Поддержка Проблемы и решения Обновление до 5.1.5 — не работает редактор

  • Сегодня WordPress автоматически обновился до версии 5.1.5. При открытии страницы визуального редактора выдается ошибка: «Произошла непредвиденная ошибка. Попытаться восстановить | Скопировать тест записи | Скопировать текст ошибки»

    Нажатие на «Попытаться восстановить» и «Скопировать текст записи» не приводит ни к каким результатам.

    При нажатии на «Скопировать текст ошибки» в буфер копируется следующее:

    TypeError: Cannot read property 'limitExceeded' of undefined
        at N.d.initialize (https:///wp-includes/js/media-views.min.js?ver=5.1.5:1:26048)
        at N.d.initialize (https://wp-includes/js/media-views.min.js?ver=5.1.5:1:28670)
        at N.d.b.View (https:///wp-includes/js/backbone.min.js?ver=1.2.3:1:14137)
        at N.d.constructor (https:///wp-includes/js/wp-backbone.min.js?ver=5.1.5:1:2616)
        at N.d.constructor (https:///wp-includes/js/media-views.min.js?ver=5.1.5:1:23607)
        at N.d [as constructor] (https:///wp-includes/js/backbone.min.js?ver=1.2.3:1:22093)
        at N.d [as constructor] (https:///wp-includes/js/backbone.min.js?ver=1.2.3:1:22093)
        at new N.d (https:///wp-includes/js/backbone.min.js?ver=1.2.3:1:22093)
        at Object.wp.media (https:///wp-includes/js/media-models.min.js?ver=5.1.5:1:1153)
        at new t (https:///wp-includes/js/dist/edit-post.min.js?ver=3.1.11:12:6517)
Просмотр 8 ответов — с 1 по 8 (всего 8)
  • Модератор Yui

    (@fierevere)

    ゆい

    кеши почистите
    в браузере
    на сайте (страничный кеш, кеш оптимизатора ваших CSS/JS)

    Большое спасибо. Помогла очистка кэша браузера.

    Поправка. При попытке добавить изображение записи ошибка возникает снова. Избавиться от нее удается только снова очистив кэш браузера.

    Возможно ли как-то откатить это обновление?

    Модератор Yui

    (@fierevere)

    ゆい

    обновление связано с безопасностью, оно не должно вызывать проблем совместимости, если вы обновляли с предыдущей версии той же ветки 5.1

    Если помогает очистка кеша, значит с самим WP и его редактором все в порядке.
    Кстати, почему именно 5.1 ? Может быть у вас какой-то плагин уже с этой веткой конфликтует? Попробуйте 5.3 например или последнюю 5.4.1

    Да, wordpress обновлялся с предыдущей версии той же ветки 5.1 (автоматически, без моего подтверждения) — еще вчера все прекрасно работало.

    Использую 5.1, поскольку в консоли написано следующее: «Обновление невозможно, так как WordPress 5.4.1 требует PHP версии 5.6.20 или новее. Ваша версия PHP — 5.4.45.»

    Любая попытка вставить блок с изображением, а также установить главное изображение поста вызывает эту «непредвиденную ошибку». При этом дальнейшее редактирование поста становится невозможным.

    Что мешает перейти на современную версию РНР 7.х?

    Переход на РНР 7.х будет выполнен. Однако прямо сейчас хочется решить проблему с обновлением 5.1.5. менее трудоемким и рискованным путем. Возможно ли это?

Просмотр 8 ответов — с 1 по 8 (всего 8)