Поддержка Проблемы и решения Ошибка обновления плагинов после установки WordPress 4.6

  • Решено gkovaleff

    (@gkovaleff)


    Приветствую!
    После обновления WP до 4.6 не удается обновить ни один плагин. Получаю сообщение:
    «Загрузка не удалась. cURL error 23: Failed writing body (624 != 811)»
    РНР 5.6, хостинг reg.ru
    Подскажите, что делать!

Просмотр 15 ответов — с 46 по 60 (всего 84)
  • Модератор SeVlad

    (@sevlad)

    wp.me/3YHjQ

    vennvarg, а что за хостинг?

    hts.ru

    Модератор Yui

    (@fierevere)

    ゆい

    кому не помогло — пишите пожалуйста версию curl из phpinfo()
    если еще не написали, пока что проблема есть на старых и очень старых версиях, насколько я вижу,
    даже с относительно новой версией php

    а какая версия сurl и php нужна?

    Модератор Yui

    (@fierevere)

    ゆい

    ну у меня например корректно работает с php 5.5.38 и 7.0.10
    curl v 7.50.1 (последняя версия curl — 7.50.2)
    openssl 1.0.2h

    PHP 5.4.45
    cURL support enabled
    cURL Information 7.19.7
    OpenSSL support enabled

    Не работает обновление плагинов..

    Пишет:
    Обновление не удалось: Загрузка не удалась. cURL error 23: Failed writing body (654 != 788)

    • Ответ изменён 3 years, 2 months назад пользователем  tsyganov.
    • Ответ изменён 3 years, 2 months назад пользователем  tsyganov.

    Тоже самое

    Обновление не удалось: Загрузка не удалась. cURL error 23: Failed writing body (611 != 814)

    PHP Version 5.3.29
    cURL Information 7.19.7
    OpenSSL 1.0.1

    Версия была 4.6 в ручную поставил 4.6.1, но проблема осталась

    Переключение версии php на 5.6 решило проблему. Все обновляется автоматически.

    Переключение версии php на 5.6 решило проблему. Все обновляется автоматически.

    Обновил тоже до 5.6, проблема осталась

    В моей проблеме помог хостер, сначала он отписал, что

    23 код ошибки для curl обычно говорит о проблемах с дисковым пространством. Но в Вашем случае таких проблем нет. Пожалуйста, предоставьте доступ к admin-панели сайта, а также дайте пошаговую инструкцию для воспроизведения ошибки с нашей стороны. Постараемся проверить и решить проблему нашими силами.

    И в итоге всё заработало

    после отключения mbstring.func_overload

    Модератор Yui

    (@fierevere)

    ゆい

    после отключения mbstring.func_overload

    очень странно, поскольку никак не связано с curl, если только старая версия curl не пытается что-то делать с кодировками, есть очень старые багрепорты с ошибкой 23 из за багов с iconv. Конверсия кодировок может приводить к разнице в байтах в теле ответа сервера.
    mbstring.overload

    Модератор Yui

    (@fierevere)

    ゆい

    тем не менее, у кого еще остались проблемы с curl 23
    попробуйте добавить в .htaccess

    
    php_admin_value mbstring.func_overload 0
    

    После добавления в .htaccess ошибка 500
    PHP Version 5.2.10
    cURL support enabled
    cURL Information libcurl/7.15.5 OpenSSL/0.9.7e zlib/1.2.3

    Обновлять php не пробовал, пока нету доступа.
    Откатывал wp до версии 4.5.3 как здесь советовали проблема осталась.
    На хостинге mchost все работает, на nic.ru плагины не обновляются, вп самостоятельно тоже и каруселька Logo Carousel Free — вообще отвалилась.

    Вот mchost:
    PHP Version 5.6.24
    cURL support enabled
    cURL Information 7.50.1

    Модератор SeVlad

    (@sevlad)

    wp.me/3YHjQ

    на nic.ru плагины не обновляются

    Хотя это и не хостинг, который стоит использовать, но сделайте скриншот включённых расширений php. Всех расширений — они там под ссылочкой отрываются. (я вроде недавно на 5,6 там обновлял плагины.)

    Хотя это и не хостинг, который стоит использовать

    Понимаю и вряд ли, когда-нибудь стал бы на нем размещать свой проект.
    Сделал сайт заказчику, а он попросил перенести его именно на этот хостинг.

    Скрины выложу, как появится возможность, доступа к хостингу пока нету 🙁

Просмотр 15 ответов — с 46 по 60 (всего 84)
  • Тема «Ошибка обновления плагинов после установки WordPress 4.6» закрыта для новых ответов.