• Здравствуйте! При обновлении выскочила Ошибка синтаксического анализа
    Parse error: syntax error, unexpected ‘[‘ in /var/www/u0421549/public_html/poisks4astya.ru/wp-content/plugins/ulogin/ulogin.php on line 437
    Что это? Помогите,пожалуйста исправить!Как восстановить сайт? Сайт не доступен.
    «Ошибка синтаксического анализа: синтаксическая ошибка, неожиданный ‘[‘ в /var/www/u0421549/public_html/poisks4astya.ru/wp-content/plugins/ulogin/ulogin.php на линии 437»

    • Тема изменена 5 лет, 9 месяцев назад пользователем dianadyubo.
    • Тема изменена 5 лет, 9 месяцев назад пользователем dianadyubo.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 14 ответов — с 1 по 14 (всего 14)
  • Parse error: syntax error, unexpected ‘[‘ in /var/www/u0421549/public_html/poisks4astya.ru/wp-content/plugins/ulogin/ulogin.php on line 437

    Совершенно очевидно, что проблема связана с плагином ulogin

    Как восстановить сайт?

    Деактивировать (удалить) проблемный плагин через ФТП соединение или менеджер файлов в панели управления хостингом

    Модератор Юрій

    (@yube)

    неожиданный ‘[

    Скорее всего, у Вас слишком старая (для этого плагина) версия PHP.

    Кстати ошибка уже известная. Но авторы плагина на это не ответили https://wordpress.org/support/topic/error-after-upgrade-to-2-9-0/

    Огромное Вам спасибо за помощь, Spectrum 🙂

    Юрий:<Скорее всего, у Вас слишком старая (для этого плагина) версия PHP.<
    Юрий, мне нужно обновить РНР? как это сделать? К сожалению, я только учусь:) Не смогла удалить плагин… пока не получается(

    Попробуйте вместо ulogin вот этот https://ru.wordpress.org/plugins/super-socializer/. В нем регистрация через соц сети, кнопки «поделиться» соц сетей и комментарии через соц сети.

    мне нужно обновить РНР? как это сделать?

    Обычно управление версией php там где регистрация и управление доменом. Сейчас актуальна версия php 7.1

    Модератор Yui

    (@fierevere)

    永子

    мне нужно обновить РНР?

    5.3.28 — очень старая версия
    Обновить обычно можно в настройках панели хостинга, там бывает выбор версии PHP
    Лучше всего сейчас использовать 7.1
    Также можете задать вопрос в техподдержку хостинга как обновить PHP

    https://ru.wordpress.org/support/upgrade-php/
    ну и вот можно почитать в тему

    Не смогла удалить плагин… пока не получается

    Чтобы деактивировать плагин надо произвольно переименовать его каталог (папку) на хостинге через FTP или менеджер файлов хостинга. Каталог плагина находится по пути: Корневая папка сайта-wp-content-plugins-ulogin. (Если удалить — удалить его папку). Чтобы активировать вновь после устранения проблем с версией php — вернуть папке прежнее имя и в админке, в разделе «Плагины» вновь его активировать. Все настройки плагина будут сохранены.

    • Ответ изменён 5 лет, 9 месяцев назад пользователем O.
    • Ответ изменён 5 лет, 9 месяцев назад пользователем O.
    • Ответ изменён 5 лет, 9 месяцев назад пользователем O.

    Обычно управление версией php там где регистрация и управление доменом.
    очепятка

    очепятка

    У меня сайты были на 3-х разных хостингах. И везде было примерно так: http://joxi.ru/nAyvoyZCYMypQr

    • Ответ изменён 5 лет, 9 месяцев назад пользователем O.
    • Ответ изменён 5 лет, 9 месяцев назад пользователем O.

    Вы написали «доменом»
    наверное хотели сказать хостингом

    • Ответ изменён 5 лет, 9 месяцев назад пользователем qwert555.

    Вы написали «доменом»

    Именно управление доменом на хостинге.http://joxi.ru/nAyvoyZCYMypQr

    Модератор Yui

    (@fierevere)

    永子

    расставлять точки над ё похоже мне

    управление доменом (DNS) — управление регистрацией, продлением доменного имени, NS серверами (делегирование), записями DNS

    то, что на скрине — управление сайтами, который приведены в списке по их FQDN (доменному имени) — версия и конфигурация PHP, настройки сайтов и прочее

    мухи <—————> котлеты

    а то, что у некоторых все свалено в одну кучу… возможно удобно, но не совсем правильно с точки зрения «разделения труда и полномочий»

Просмотр 14 ответов — с 1 по 14 (всего 14)
  • Тема «Ошибка синтаксического анализа при обновлении.» закрыта для новых ответов.