Поддержка Проблемы и решения Ошибка установки соединения с базой данных

  • VPS Debian 8 + Apache+php+mysql
    ставил из репозиториев, конфиги не менял
    Wordpress+woocommerce+плагины (практически последние версии)

    Наверно уже три недели мучаюсь. (
    Ситуация такая — сайт работает и внезапно (через день, два или 5 минут) возникает сообщение «Ошибка установки соединения с базой данных».
    Сайт никто кроме меня не посещает.

    Первое что подумал — mysql. Логи. Пусто.
    Вопрос хостеру — вы ли это? Хостер нет не мы. И, похоже на правду.
    Ведь последнее падение произошло сразу через 5 минут после перезапуска сервера.

    Ресурсы сервера? Проапгрейдил. Слежу за использованием.
    Процессор не нагружается выше 30%, Память около 50-60%. «Дисковой квоты» полно.

    Думаю, что дело в WordPress, woocommerce или плагинах.
    Плагины ставил из WordPress. Все совместимые. Все с высоким рейтингом от 500000 установок.

    Почему думаю что виноват WordPress?
    Часть лога апача

    [Mon Apr 23 17:08:38.715081 2018] [:error] [pid 1233] [client 84.1.159.5:44610] \x85 WordPress \xd0\x83 Lost connection to MySQL server during query \xd0\x81 SELECT option_value FROM wp_options WHERE option_name = 'wbcr_clearfy_disable_comments_for_post_types' LIMIT 1, \xd0\xb9 include('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('wp_loaded'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WbcrCmp_ConfigComments->initWploadedFilters, WbcrCmp_ConfigComments->getDisabledPostTypes, WbcrFactoryClearfy_Configurate->getOption, get_option
    [Mon Apr 23 17:08:39.090893 2018] [:error] [pid 1217] [client 84.1.159.5:34746] \x85 WordPress \xd0x83 Lost connection to MySQL server during query \xd0x81 SELECT option_value FROM wp_options WHERE option_name = 'wbcr_clearfy_disable_comments_for_post_types' LIMIT 1, \xd0\xb9 include('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('wp_loaded'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WbcrCmp_ConfigComments->initWploadedFilters, WbcrCmp_ConfigComments->getDisabledPostTypes, WbcrFactoryClearfy_Configurate->getOption, get_option
    [Mon Apr 23 17:08:39.304561 2018] [:error] [pid 1290] [client 84.1.159.5:36812] \x85 WordPress \xd0x83 Lost connection to MySQL server during query \xd0x81 SELECT option_value FROM wp_options WHERE option_name = 'wbcr_clearfy_disable_emoji' LIMIT 1, \xd0\xb9 include('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('plugins_loaded'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, wbcr_clearfy_plugin_init, WbcrFactoryClearfy_Configurate->__construct, WbcrClearfy_ConfigCodeClean->registerActionsAndFilters, WbcrFactoryClearfy_Configurate->getOption, get_option
    [Mon Apr 23 17:08:39.514153 2018] [:error] [pid 1353] [client 84.1.159.5:37566] \x85 WordPress \xd0x83 Lost connection to MySQL server during query \xd0x81 SELECT option_value FROM wp_options WHERE option_name = 'wp_mail_smtp' LIMIT 1, \xd0\xb9 include('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('plugins_loaded'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WPMailSMTP\\Core->init_notifications, WPMailSMTP\\Options::init, WPMailSMTP\\Options->__construct, WPMailSMTP\\Options->populate_options, get_option
    [Mon Apr 23 17:08:39.563516 2018] [:error] [pid 1263] [client 84.1.159.5:43120] \x85 WordPress \xd0x83 Lost connection to MySQL server during query \xd0x81 SELECT option_value FROM wp_options WHERE option_name = 'ossdl_https' LIMIT 1, \xd0\xb9 include('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), include_once('/plugins/wp-super-cache/wp-cache.php'), include_once('/plugins/wp-super-cache/ossdl-cdn.php'), get_option
    [Mon Apr 23 17:08:57.091527 2018] [:error] [pid 1165] [client 84.1.159.5:48346] PHP Warning:  mysqli_query(): (HY000/2013): Lost connection to MySQL server during query in /var/www/html/wp-includes/wp-db.php on line 1924

    Лог апача
    https://cloud.mail.ru/public/2Wsw/yNdtKsbAc

    Что делать?

    • Тема изменена 6 лет назад пользователем unity555.
    • Тема изменена 6 лет назад пользователем Yui.
Просмотр 8 ответов — с 16 по 23 (всего 23)
  • Модератор Yui

    (@fierevere)

    永子

    поставили свой и зашли на него только вы?
    прочитайте еще раз то, что я написала выше, апач выделяет ресурсы на каждое принятое им соединение, а у вас в конфигурации разрешено их принимать больше, чем есть памяти на сервере.

    проблема не в вп или чем-то еще, а в том что должно обеспечивать работу вп, в вебсервере, точнее неправильной его настройке.

    сколько нужно ресурсов — зависит от настроек вебПО, моим подопечным 1 гб хватает на несколько вордпрессов (сайтов) втч и один с вукоммерц и еще куча ресурсов свободны. вариантов полно как настраивать сервер, также как и форумов по системному администрированию, а вордпресс и его аппетиты тут непричем, совсем

    поставили свой и зашли на него только вы?

    От 10 до 100 онлайн. В зависимости от решения. Работает на VPS, Raspberry, микроконтроллерах. Ошибок нет, проблем нет.

    апач выделяет ресурсы на каждое принятое им соединение.

    Удалил апач. Поставил lighttpd.
    https://www.howtoforge.com/tutorial/install-lighttpd-with-php-fpm-and-mysql-on-debian/
    Тестирую.
    Смотрю доступность. Буду загружать loadimpact и аналогами.
    Жду когда упадет..

    С учетом нагрузки 3 пользователя онлайн?
    Что нужно для гарантированного результата безотказной работоспособности системы под данной нагрузкой?

    вам же уже сказали — ограничьте форки апача.
    сколько у вас там процессов запущено то?
    при 1Гб памяти 5 копий апача максимум.

    Удалил апач. Поставил lighttpd.

    ставьте nginx сразу, nginx+phpfpm — в 5 раз быстрее апача, где php модулем стоит.

    anonymized-14765447

    (@anonymized-14765447)

    ставьте nginx сразу

    Ему уже советовали, и, видимо, не зашло 🙂

    вам же уже сказали — ограничьте форки апача.

    Все уже. Нет апача. Да здравствует lighttpd(?)

    Ему уже советовали, и, видимо, не зашло

    Ну почему же не зашло. Не ставил пока.
    Имеет смысл nginx+phpfpm?

    А то Настройки постоянных ссылок(mod_rewrite) опять не работают.
    Работают только простые ссылки. А с ними supercache не работает.

    И woocommerce отображает по 3 товара на странице.
    Откуда, почему, кто так сделал? Я ничего не делал. Настройки не менял.
    Чудеса переустановки.

    Модератор Yuri

    (@yube)

    А то Настройки постоянных ссылок(mod_rewrite) опять не работают.

    .htaccess читает только Апач. У прочих демонов свои конфиги, в которые для ЧПУ нужно вносить правила. Нет правил — нет ЧПУ.

    А то Настройки постоянных ссылок(mod_rewrite) опять не работают.

    для nginx в конфиге надо прописать:

    
    location / {
        # ЧПУ для WordPress.
        try_files $uri $uri/ /index.php?$args;
    }
    

    об этом есть в кодексе.

Просмотр 8 ответов — с 16 по 23 (всего 23)
  • Тема «Ошибка установки соединения с базой данных» закрыта для новых ответов.