Поддержка Проблемы и решения Перестал работать сайт в вордпресс

  • Перестал работать небольшой сайтик, пришло смс от яндекс метрики, что он для него недоступен.

    Хост в порядке, работ с сайтом не проводилось, в админку зайти не могу, на сайт тоже, выдает 500 ошибку.

    Хелп, что могло поломаться?

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 15 ответов — с 1 по 15 (всего 20)
  • Смотрите логи ошибок. 500-ая ошибка — ошибка сервера. Как правило — не хватка ресурсов.

    Где посмотреть лог ошибок

    php не обновляли?

    лог ошибок ищите в панели хостинга.

    или можете сразу задать вопрос в ТП хостинга

    Хостинг бегет

    пхп не обновлял, стоит 5.6. с рождения
    журналы оказывается были выключены)

    включайте и смотрите какая будет ошибка.
    кстати РНР надо бы обновить. Рекомендуемая версия 7,2 для текущей версии ВП.

    Спасибо, вопрос решен, глючил плагин.

    Заработала только центральная страница)

    по сотальным выдает ошибку

    Not Found
    The requested URL /category/zoj/ was not found on this server.

    Apache/2.4.10 (Unix) Server at cultureoflife.ru Port 80

    Поддержка ответила вот что))

    Здравствуйте!

    Насколько я вижу, проблема возникает из-за некорректной работы php-скрипта. Прикладываю фрагмент лога ошибок:

    PHP Fatal error: require_once(): Failed opening required ‘/home/r/resurshx/cultureoflife.ru/public_html/wp-content/plugins/vkontakte-api/includes/class-factory-requirements.php’ (include_path=’.:/usr/share/php’) in /home/r/resurshx/cultureoflife.ru/public_html/wp-content/plugins/vkontakte-api/vkontakte-api.php on line 33

    Судя по всему это связано с недавними проблемами плагина vkontakte-api. Переименовал папку с плагином, сайт возобновил работу. Для решения проблемы рекомендуем обратиться в поддержку разработчика плагина или попробовать заменить его аналогичными плагинами.

    Плагин снес)

    странно как то,всё заработало, пхп обновил до 7.3 и вообще все плагины и сам вордпресс

    а теперь вообще всё сломалось) после обновления пхп в консоли)

    а чего странного-то, если все заработало?

    крч, все стало хорошо, с 7.3. пхп был не совместим плагиг амр страниц, отключил его и всё заработало.

    хотя амр тоже хорошо

    Модератор Юрий

    (@yube)

    [offtop]
    «Живым всё хорошо»
    (хф «Формула любви»)
    извините, не сдержался

    У меня вчера тоже была проблема с плагином vkontakte-api . Но мне пришло письмо:

    “Your Site is Experiencing a Technical Issue”

    Howdy!

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with one of your plugins, VKontakte API – crossposting, comments, social buttons, login.

    Error Details
    =============
    An error of type E_COMPILE_ERROR was caused in line 33 of the file /home/mknowovf/public_html/wp-content/plugins/vkontakte-api/vkontakte-api.php. Error message: require_once(): Failed opening required ‘/home/mknowovf/public_html/wp-content/plugins/vkontakte-api/includes/class-factory-requirements.php’ (include_path=’.:/opt/cpanel/ea-php72/root/usr/share/pear’)

    Смог войти в админку только когда переименовал через FTP папку Вашего плагина.

    Проблема с плагином vkontakte-api

    Тему подняли, пишут что откатили на рабочую версию

    https://wordpress.org/support/topic/your-site-is-experiencing-a-technical-issue-11/

Просмотр 15 ответов — с 1 по 15 (всего 20)
  • Тема «Перестал работать сайт в вордпресс» закрыта для новых ответов.