Поддержка Плагины Плагин не был активирован, потому что он вызвал фатальную ошибку.

  • Плагин не был активирован, потому что он вызвал фатальную ошибку.

    Parse error: syntax error, unexpected ‘[‘ in /var/www/u6614671/data/www/xn--b1ab7abbkcifc5hub.xn--p1ai/wordpress/wp-content/plugins/disable-xml-rpc-littlebizzy/admin-notices-ms.php on line 85

    Вод код

    
    		// Done
    		return self::$instance;
    	}
    
    	/**
    	 * Constructor
    	 */
    	private function __construct($plugin_file = null) {
    
    		// Main plugin file
    		$this->plugin_file = isset($plugin_file)? $plugin_file : __FILE__;
    
    		// Admin notices both in admin and network admin
    85		add_action('admin_notices', [&$this, 'adminNoticesMS']);
    86		add_action('network_admin_notices', [&$this, 'adminNoticesMS']);
    	}
    

    Что же тут не так? Как обычно установил плагин Disable XML-RPC Который оновлялся месяц назад, было написано, что совместим с моей версией wordpress, а при активации выдал вот эту ошибку. Что делать то?

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 8 ответов — с 1 по 8 (всего 8)
  • Что же тут не так?

    Требуется более высокая версия PHP.

    Спасибо!

    А что делать Если при включении версии PHP выше у меня перестает отображаться весь сайт?

    А что делать

    Разбираться, смотреть логи ошибок php…

    Тут одно из двух: либо «законсервировать» сайт и ничего не обновлять и не добавлять (речь не о контенте, а о скриптах, разумеется), либо обновлять всё, а что не обновляется, то менять на новое, современное. Но чем дольше софт не обновляется, тем больнее потом неизбежное обновление. А оно рано или поздно случится.

    Так как сайт у меня пока в стадии начала, то я решил на хостинге все удалить, в месте с базой данных и по новой установить wordpress, но перед этим изменить настройки PHP на более новую версию. А какую версию вы посоветуете мне поставить? Есть варианты 5.4, 5.4.with-xcache, 5.5, 5.6, 7.0, 7.1, 7.2, стояла 5.3.with-xcache А какую верси вы посоветуете поставить и какую версию SQL лучше выбрать?

    А какую версию вы посоветуете мне поставить?

    Я бы выбрал 7.0 модуль apache (да, я консерватор)

    какую версию SQL лучше выбрать?

    А у Вас есть выбор?
    MySQL (обязательно) ver 5.7 (желательно)

    Я бы выбрал 7.0 модуль apache

    А я бы 7,1 LSAPI 😉
    Особенно если шаред.

    nginx + phpfpm (php 7.1), идеальная конструкция, которая и дает те самые 30-50мс на генерацию главной страницы сайта сразу после установки движкаю

Просмотр 8 ответов — с 1 по 8 (всего 8)
  • Тема «Плагин не был активирован, потому что он вызвал фатальную ошибку.» закрыта для новых ответов.