Поддержка Проблемы и решения Полоса внешний вид>настройки

  • Когда перехожу настроить виджеты на страницах, появляется простыня, перекрывающая почти весь сайт, скрин https://i.yapx.ru/FIM7v.png, когда на главной странице настраиваешь такого нет.
    И это у меня на двух сайтах так! Пользуюсь яд браузером, Пару дней назад настраивал с гугл хрома, всё нормально было , теперь и с хрома так! Что сделать можно? плагины отключал, темы менял, но бестолку

    • Тема изменена 2 нед., 3 дн. назад пользователем  Алексей.
Просмотр 11 ответов — с 1 по 11 (всего 11)
  • у меня та-же проблема, очень неудобно, может кто поможет ее решить. Если сам найду решение раньше, отпишу.

    Модератор Yui

    (@fierevere)

    ゆい にゃん子

    @kaprilies
    правила форума п2

    я не поверю что у вас с автором темы, одна и та же тема оформления, один и тот же набор плагинов, версия WP, хостинг, один сайт… и вообще вы близнецы братья

    Вообщем на мозиле все работает
    На хроме и яд браузера полоса
    хз что такое
    темы менял
    плагины фиксил
    дебаг включал

    • Ответ изменён 2 нед., 2 дн. назад пользователем  Алексей.

    @kaprilies у меня в мозиле работает нормально)

    @fierevere Понятное дело что темы у нас разные, в том числе набор плагинов, версия php и тд. У меня лично премиум тема, со своими функциями.

    Я отписался автору темы, не как с вопросом, а что бы держать друг друга в курсе, если кто-то из нас найдет решение проблемы быстрее, поэтому не понятно к чему тут п.2 правил форума.

    Для примера http://prntscr.com/ozawa8

    Я сам удивился что моя проблема совпала по времени с проблемой Алексея, поэтому не создавал такой же вопрос, и решил ожидать ответа в этой теме.

    @presiident другие браузеры не пробовал, вся работа в Хроме :( но спасибо за подсказку, вдруг что, попробую на Мозиле.

    у меня мой шаблон.. т.е сам его писал

    • Ответ изменён 2 нед., 2 дн. назад пользователем  Алексей.

    у меня мой шаблон.. т.е сам его писал

    Ну тогда это у вас нужно спросить, почему так происходит.
    Нам не ведома, что вы там понаделали.

    @presiident а, что ты из последнего добавлял на сайт?
    Я обновлял версию php до 7.3 и помнится недавно было обновление плагина YoastSEO.
    Проблема оказывается в том что, прописывается для параметра кастомайзера дополнительный стиль
    element.style {
    height: auto !important;
    }
    если его выключить, стает все на место.
    !important перекрывает высоту нашего стиля
    Вот он — http://prntscr.com/ozr4yo
    выключен — http://prntscr.com/ozr5we
    Я пробовал отключать все плагины, смотрел что может дописывать стиль, ничего не нашел 🙁
    Раз у нас похожая проблема, может ты что-то вспомнишь 🙂

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Проблема оказывается в том что, прописывается для параметра кастомайзера дополнительный стиль element.style { height: auto !important; }

    В ядре такого нет — предполагаю, что проблема в одном из недавних обновлений плагинов или темы оформления.

    помнится недавно было обновление плагина Yoast SEO

    Проверил с ним, но не воспроизвелось.

    Стоит выполнить пункты 4—6.

    @kaprilies да всё тоже примерно, что и у тебя!
    Проблема ушла, причины неизвестны =)

    • Ответ изменён 4 дн., 16 час. назад пользователем  Алексей.

    @presiident У меня проблема тоже ушла, но магическим способом 🙂 Прочитал на форуме что проблема у некоторых возникала из-за плагина WP Rollback, после его отключения ставало все на место.
    Понятно, что такого плагина у меня не было, но решил поиграться, установил этот плагин и деактивировал, и проблемы не стало. Каким то образом убрало стиль с параметром !important. В общем надеюсь эту ошибку я видел в последний раз 🙂

Просмотр 11 ответов — с 1 по 11 (всего 11)