Поддержка Проблемы и решения После обновления всё сломалось помогите

  • Боже, всё было хорошо, чёрт меня дернул обновить всё… Теперь выдает кучу ошибок, я их не понимаю. Всё на сайте делала сама, всё было понятно два года, ни одной ошибки не было. Теперь не пойми что. Не могу найти как выложить скрины.
    Здоровье сайта:
    1. Ваша версия PHP требует обновления. Минимальная рекомендуемая версия PHP — 7.3.PHP
    2. Определение WP_DEBUG_DISPLAY было либо включено константой WP_DEBUG, либо добавлено в файл конфигурации. Ошибки будут показаны в браузере на части сайта для посетителей.
    3. Фоновые обновления работают неправильно.
    — Ошибка Плагин предотвращает обновления отключением wp_version_check().

    Вверху шапки сайта пишет: Notice: Use of undefined constant wcbtn_woocommerce_not_active_notice — assumed ‘wcbtn_woocommerce_not_active_notice’ in /home/users/ellasuhvall_wp1/site/wp-content/plugins/woocommerce-better-thumbnail-navigation/woocommerce-better-product-thumbnail-navigation.php on line 127

    «Отзывы» не отображает (пишет: Notice: Use of undefined constant wcbtn_woocommerce_not_active_notice — assumed ‘wcbtn_woocommerce_not_active_notice’ in /home/users/ellasuhvall_wp1/site/wp-content/plugins/woocommerce-better-thumbnail-navigation/woocommerce-better-product-thumbnail-navigation.php on line 127

    Warning: Cannot modify header information — headers already sent by (output started at /home/users/ellasuhvall_wp1/site/wp-content/plugins/woocommerce-better-thumbnail-navigation/woocommerce-better-product-thumbnail-navigation.php:127) in /home/users/ellasuhvall_wp1/site/wp-includes/pluggable.php on line 1265 )

    Подскажите пожалуйста что тут можно сделать, как лечить?

    • Тема изменена 1 месяц, 3 недели назад пользователем ellasuhvall.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 6 ответов — с 1 по 6 (всего 6)
  • Ничо не понятно, что обновили, плагины или wp?
    очевидно раз просит обновит php значит надо обновить php, возможно плагины просто некорректно работают с этой версией php
    перед такими манипуляциями надо делать бекап с помощью duplicator.

    попробуйте обновить php или сначала отключить плагины и поочередно их включать чтобы понять какой выдает ошибку(вангую woocommerce)

    • Ответ изменён 1 месяц, 3 недели назад пользователем .

    https://ru.wordpress.org/plugins/woocommerce-better-thumbnail-navigation/
    Плагин 4 года как не поддерживается.
    Не удивительно что он конфликтует со всем остальным.

    Спасибо вам добрые люди! woocommerce ЗЛО,я не знала!

    WC не зло
    у вас не работает другой плагин, пристройка к WC
    обновлять чаще надо и следить за сайтом)

    я удалила woocommerce и всё заработало. а нужно было другое что то? что за пристройка?)

    я удалила woocommerce и всё заработало

    Все правильно.
    Резать к чертовой матери, не дожидаясь перитонита! ©

Просмотр 6 ответов — с 1 по 6 (всего 6)