Поддержка Проблемы и решения После обновления до 4.7.1 перестали загружаться docx файлы

  • Проверил в mime разрешения есть в funcions.php , пробовал дать разрешения на типы файлов через разные плагины. Результат 0. Постоянно получаю «Извините, тип этого файла не разрешён из соображений безопасности.»
    Скажите в какую сторону копать?
    Попытался откатиться на предыдущую версию из бэкапа, но движек сразу же обновился.

Просмотр 15 ответов — с 1 по 15 (всего 27)
  • только что попробовал на 4.7.1 — загрузилось.
    и без всякого кода в functions.php

    поэтому начните с отключения этого вашего кода.

    так я ничего не добавлял, просто открыл файл и посмотрел, какие типы файлов разрешены. Вот в чем вопрос, я же из бэкапа полнолстью откатил и базу и файлы.

    Поддерживаю вопрос.

    После обновления до 4.7.1 *.docx файлы не загружаются — «Извините, тип этого файла не разрешён из соображений безопасности.»

    Проверил наличие разрешенных типов в wp-inludes/functions.php, и на всякий случай в wp-includes/js/plupload/plupload.full.min.js и wp-admin/includes/schema.php везде есть docx среди разрешенных файлов.

    Где может крыться проблема?

    Времмено использую костыль. в формате doc все загружается, сохранил и загрузил в нем.

    Да doc грузиться без проблем.
    Но вот клиенты балованные — «хочу чтоб все работало» ))

    Модератор Denis Yanchevskiy

    (@denisco)

    WordPress-разработчик, wpcute.ru

    Скажите в какую сторону копать?

    Пока, видимо, ни в какую. Есть тикет с данной проблемой, предположительно должно быть исправлено в WP 4.7.2.

    Наверное временно можно попробовать использовать код отсюда https://codex.wordpress.org/%D0%A7%D0%90%D0%92%D0%9E/%D0%9A%D0%B0%D0%BA_%D0%B7%D0%B0%D0%B3%D1%80%D1%83%D0%B7%D0%B8%D1%82%D1%8C_%D0%BD%D0%B5%D1%81%D1%82%D0%B0%D0%BD%D0%B4%D0%B0%D1%80%D1%82%D0%BD%D1%8B%D0%B9_%D1%84%D0%B0%D0%B9%D0%BB или же поставить какой-нибудь подходящий плагин https://wordpress.org/plugins/search.php?q=mime

    • Ответ изменён 3 года, 5 месяцев назад пользователем SeVlad.
    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    До официального исправления попробуйте добавить фрагмент в functions.php активной темы:

    
    function wp39550_disable_real_mime_check( $data, $file, $filename, $mimes ) {
    	$wp_filetype = wp_check_filetype( $filename, $mimes );
    
    	$ext = $wp_filetype['ext'];
    	$type = $wp_filetype['type'];
    	$proper_filename = $data['proper_filename'];
    
    	return compact( 'ext', 'type', 'proper_filename' );
    }
    add_filter( 'wp_check_filetype_and_ext', 'wp39550_disable_real_mime_check', 10, 4 );
    

    SeVlad, не поможет.
    Оба варианта цепляются к фильтру «upload_mimes», добавляют или удаляют элементы в стандартном наборе «mime_types», который в wp-inludes/functions.php. Но docx там и так присутствует.

    • Ответ изменён 3 года, 5 месяцев назад пользователем rogodessa.

    Sergey Biryukov, спасибо!

    Как временный вариант подойдет, главное работает ))

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Оформил временное решение в виде плагина: Disable Real MIME Check.

    Официальное исправление должно быть в WordPress 4.7.2 — выход изначально планировался в феврале, но об этой проблеме, затронувшей многих пользователей, тогда ещё не было известно. Возможно, выйдет и раньше.

    Всем спасибо! Ждем обновления.

    Наблюдается не на всех проектах с версией WP 4.7.1.
    Возможно играет роль установленная тема.

    Громадная благодарность Сергею за решение!

    После установки плагина Disable Real MIME Check файлы pdf, doc загружаются. Спасибо.

    Сергей, большое человеческое спасибо! Вы просто мой спаситель! Плагин замечательно работает!!!

    • Ответ изменён 3 года, 5 месяцев назад пользователем irLioness.
Просмотр 15 ответов — с 1 по 15 (всего 27)
  • Тема «После обновления до 4.7.1 перестали загружаться docx файлы» закрыта для новых ответов.