Поддержка Проблемы и решения После обновления сайт выглядит по другому

  • Решено АВТО INFO

    (@jackson1979)


    После обновления WordPress до версии 5.7 страницы записей выглядят по другому. В частности, после установленных в контенте рекламных блоков появился очень большой пробел, которого раньше не было. Выглядит очень коряво. Способа от него избавится я так и не нашёл. У кого нибудь есть подобная проблема или это только мне так «повезло»?
    Прошу либо помочь в решении этой проблемы, либо прошу разработчиков обратить на неё внимание и устранить в следующем обновлении.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 5 ответов — с 1 по 5 (всего 5)
  • Автор АВТО INFO

    (@jackson1979)

    Проблема решена и тему можно удалять. В общем, в файле style.min.css, который находится по адресу wp-includes/css/dist/block-library/ изменил это:

    p:empty:before {
        content: "";
    }

    На это:

    p:empty:before {
        /* content: ""; */
    }

    И пробел (абзац) после рекламных блоков исчез.

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    В общем, в файле style.min.css, который находится по адресу wp-includes/css/dist/block-library/ изменил это

    Спасибо, что поделились! Направление верное, но вместо правки файлов ядра я бы посоветовал в качестве временного решения добавить следующий фрагмент в разделе «Внешний вид» → «Настроить» → «Дополнительные стили»:

    
    body p:empty:before {
    	content: none;
    }
    

    Проблема связана с изменением стилей абзацев в PR 27995, которое должно было сделать отображение контента на внешней части сайта более похожим на то, как он выглядит в редакторе. Но при этом не было учтено, что пустые теги <p></p> могут быть и не добавлены пользователем вручную, а появляться из-за других факторов — например, не всегда корректной работы плагинов или функции wpautop().

    Во всех рассмотренных на данный момент случаях пустые теги <p></p> не появились в WP 5.7, а уже были в коде страницы и в предыдущих версиях, просто сейчас они стали видимы.

    Следить за исправлением в WP 5.7.1 или подключиться к обсуждению можно в тикете #52764.

    Автор АВТО INFO

    (@jackson1979)

    Спасибо. Указанное вами решение я тоже пробовал, но оно по непонятным мне причинам не сработало. Возможно, что я где-то допустил ошибку, найти которую мне не удалось и я решил править файлы ядра.

    Автор АВТО INFO

    (@jackson1979)

    В общем, я решил восстановить файл ядра и воспользоваться указанным выше временным решением. В первый раз я действительно допустил ошибку, но сейчас всё работает.

    • Ответ изменён 7 месяцев назад пользователем АВТО INFO.

    АВТО INFO, привет.

    Указанное вами решение я тоже пробовал, но оно по непонятным мне причинам не сработало.

    А если попробовать так:

    .entry-content p:empty  {
        display: none;
    }

    ?

Просмотр 5 ответов — с 1 по 5 (всего 5)
  • Тема «После обновления сайт выглядит по другому» закрыта для новых ответов.