Поддержка Проблемы и решения После перехода на https не вставляются в редакторе картинки в текст статьи

  • Переводила сайт с http на https. Протокол SSL подключили на хостинге. В Настройки – Общие поменяла адрес WP и сайта с http на https. С помощью плагина Better Search Replace поменяла оставшиеся адреса с http в БД на https. В настройках хостинга поставила галочку у пункта «Постоянное перенаправление с HTTP на HTTPS с кодом 301 без ущерба для поисковой оптимизации». Чёрный замочек остался. Посмотрела код статьи — там картинки вставляются по протоколу http. О незащищённости графических объектов говорит и информация чёрного замочка. Сегодня работала над новым постом. Фотографии не вставляются (!!!), указывается ошибка: petrowvs4.jpg Ошибка HTTP. Обращалась на хостинг, ответили: «Технический специалист проанализировал ситуацию и выяснил , что данные ошибки возникают не из за сертификата , а из за проблем работы WP с ссылками HTTP , Вам необходимо обратиться службу поддержки WordPress». Просто не знаю, что делать, помогите, пожалуйста, решить проблему.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 15 ответов — с 1 по 15 (всего 16)
  • Модератор Юрий

    (@yube)

    В браузере нажимаете F12, вкладка «Консоль» и смотрите адреса, которые Mixed Content. Там http://counter.rambler.ru/top100.jcn?2396006, http://c.luxup.ru/t/lb136933_1.js?rt=23900010029', может еще что-то.

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Посмотрела код статьи — там картинки вставляются по протоколу http.

    В записи «Штурм Кёнигсберга в 1945 году» с картинками всё ОК, загружаются по https.

    Через http загружаются только внешние счётчики:

    
    http://counter.rambler.ru/top100.jcn?2396006
    http://c.luxup.ru/t/lb136933_1.js?rt=23381410062&r=https%3A//voynablog.ru/
    

    Их тоже нужно заменить на https. Скорее всего, эти ссылки можно найти в шаблонах темы оформления.

    Автор via55

    (@via55)

    Извините, я — историк и мало понимаю в кодах. Нажимаю ctrl+u и в тексте страницы вижу и ссылки, и фото по http. М. б. я не правильно смотрю?

    Автор via55

    (@via55)

    После очистки кэша: фото указываются в тексте страницы по протоколу https. Отредактировала файлы темы: счётчики по https. Но результат — прежний. Картинки в редакторе WP в текст поста не вставляются: ошибка по HTTP. Что посоветуете сделать?

    Вообще, проблем быть не должно c https. Может быть дело в рекламе на сайте, которая мешает работать https? Если Вы временно активируете одну из тему по умолчанию, будет нормально работать https?

    • Ответ изменён 2 года назад пользователем alexander70.

    У меня на Вашей странице завис Гугл Хром. Слишком много рекламы и она агрессивная 🙂

    Автор via55

    (@via55)

    Убрала всю рекламу, кроме Гугпа (её оставила частично). Результат прежний. Подключила плагин
    really-simple-ssl. Ничего не меняется.

    SSL должно работать без всяких плагинов, только с редиректом на https. Пробовали временно активировать какую-то тему по умолчанию? Работает https с темой по умолчанию?

    Автор via55

    (@via55)

    Зелёный замочек появился!!! Исправила адреса кнопок прокрутки страницы, они у меня справа, серого цвета. Но фотографии в текст статьи в редакторе не вставляются — ошибка по http.

    Трудно сказать, в чем проблема. Я бы на Вашем месте установил новый, тестовый вордпресс в отдельной папке и смотрел уже там.

    Автор via55

    (@via55)

    Обновила WP, обновила плагины. Отключила плагин Really Simple CAPTCHA — несколько фото вставились, а затем фотографии перестали опять вставляться — ошибка HTTP! Получается, что где-то что-то не доисправлено. М.б. посоветуете к-л плагин для полной проверки. У меня сейчас подключён Really Simple SSL.

    Если вообще все плагины отключите, будут нормально картинки загружаться? Какая версия PHP на хостинге?

    Автор via55

    (@via55)

    Плагины попробую отключать по одному. Версия php 5.6.40, можно сделать выше.

    Включите 7.2 или 7.3. Если не поможет, займитесь отключением плагинов.

    Автор via55

    (@via55)

    Версия PHP 7.3. Плагины отключала по одному, проверяла и вновь включала. Картинки не вставляются. Затем все включила и начала выключать по одному, каждый раз проверяя результат. Картинки так и не вставились. Может быть, что то ещё посоветуете сделать?

Просмотр 15 ответов — с 1 по 15 (всего 16)
  • Тема «После перехода на https не вставляются в редакторе картинки в текст статьи» закрыта для новых ответов.