Поддержка Проблемы и решения после публикации записи они пропадают

  • Решено legal2019

    (@legal2019)


    Всем здравствуйте!
    Помогите пожалуйста разобраться, ни как не могу понять в чём причина.
    Описание проблемы:
    1. Захожу Записи-Добавить новую.
    2. Вставляю текст.
    3. Жму предпросмотр. Далее открывается новая вкладка «Создание предварительного просмотра…» и ничего не происходит, только рисуется знак WP. А на вкладке с текстом, около кнопки «Предпросмотр», постоянно мигает облако и слово сохранение.
    Жму Ф5+ктрл и он меня перекидывает на самую последнюю опубликованную запись.

Просмотр 15 ответов — с 1 по 15 (всего 18)
  • Перейти на реальный хостинг.

    То что вы описали это не публикация. Публикация это после написания текста нажимаете кнопку «опубликовать«.

    wpgear (@wpgear)

    Перейти на реальный хостинг.

    Что значит на реальный хостинг?
    Сайт и так находится на хостинге.

    intman1958 (@intman1958)

    То что вы описали это не публикация. Публикация это после написания текста нажимаете кнопку «опубликовать«.

    Я описал всё правильно. Попробую сделать видео и выложить чтобы было более понятно. Возможно повторюсь ещё раз…
    1. Делаю новую запись, публикую её.
    2. Делаю вторую новую запись (Захожу Записи-Добавить новую.) и далее:

    2. Вставляю текст.
    3. Жму предпросмотр. Далее открывается новая вкладка «Создание предварительного просмотра…» и ничего не происходит, только рисуется знак WP. А на вкладке с текстом, около кнопки «Предпросмотр», постоянно мигает облако и слово сохранение.
    Жму Ф5+ктрл и он меня перекидывает на самую последнюю опубликованную запись.

    Другими словами, получается так, как будто бы не новую запись пытаюсь опубликовать, а по факту старую запись редактирую. Только не понимаю, почему так происходит? Ведь когда нажимаю Записи-Добавить новую, то у меня чистый лист, как и должно быть. Далее ввожу текст, название заголовка и т.п. и потом начинается танцы с бубном…

    Может всё дело в неправильно созданных записях файла .htaccess?
    Это текущий .htaccess

    AddDefaultCharset UTF-8
    Options -Indexes
    # Закрываем доступ к файлу
    <FilesMatch "xmlrpc.php">
    Order Deny,Allow
    Deny from all
    </FilesMatch>
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^sitemap(-+([a-zA-Z0-9_-]+))?\.xml(\.gz)?$ /сайт.ru/sitemap$1.xml$2 [L]
    </IfModule>
    
    RewriteEngine On
    RewriteCond %{ENV:HTTPS} !on
    RewriteRule ^.*$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    
    <FilesMatch ".(htaccess|htpasswd|ini|phps|fla|psd|log|sh)$">
    Order Allow,Deny
    Deny from all
    </FilesMatch>
    
    <ifmodule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/shtml
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/rss+xml
    </ifmodule>
    
    <IfModule mod_gzip.c>
    mod_gzip_on Yes
    mod_gzip_dechunk Yes
    mod_gzip_item_include file \.(shtml?|html?|txt|css|js|php|pl)$
    mod_gzip_item_include handler ^cgi-script$
    mod_gzip_item_include mime ^text\.*
    mod_gzip_item_include mime ^application/x-javascript.*
    mod_gzip_item_exclude mime ^image\.*
    mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
    </IfModule>
    
    #	Redirect 301
    Redirect 301 /readme.html https://сайт.ru/readme
    #	old sait -> new sait
    #	uslugi
    Redirect 301	/services/fl/бла-бла-бла.shtml https://сайт.ru/uslugi/бла-бла-бла/
     
    # кеширование в браузере на стороне пользователя
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault "access 7 days"
    ExpiresByType application/javascript "access plus 1 year"
    ExpiresByType text/javascript "access plus 1 year"
    ExpiresByType text/css "access plus 1 year"
    ExpiresByType text/html "access plus 7 day"
    ExpiresByType text/x-javascript "access 1 year"
    ExpiresByType image/gif "access plus 1 year"
    ExpiresByType image/jpeg "access plus 1 year"
    ExpiresByType image/png "access plus 1 year"
    ExpiresByType image/jpg "access plus 1 year"
    ExpiresByType image/x-icon "access 1 year"
    ExpiresByType application/x-shockwave-flash "access 1 year"
    </IfModule>
    
    # Cache-Control
    <ifModule mod_headers.c>
    # 30 дней
    <filesMatch "\.(ico|pdf|flv|jpg|jpeg|png|gif|swf)$">
    Header set Cache-Control "max-age=2592000, public"
    </filesMatch>
    # 30 дней
    <filesMatch "\.(css|js)$">
    Header set Cache-Control "max-age=2592000, public"
    </filesMatch>
    # 2 дня
    <filesMatch "\.(xml|txt)$">
    Header set Cache-Control "max-age=172800, public, must-revalidate"
    </filesMatch>
    # 1 день
    <filesMatch "\.(shtml|html|htm|php)$">
    Header set Cache-Control "max-age=172800, private, must-revalidate"
    </filesMatch>
    </ifModule>
    
    # использование кеша браузеров
    FileETag MTime Size
    <ifmodule mod_expires.c>
    <filesmatch ".(jpg|jpeg|gif|png|ico|css|js)$">
    ExpiresActive on
    ExpiresDefault "access plus 1 year"
    </filesmatch>
    </ifmodule>
    
    #Запрет отдачи HTTP-заголовков Vary браузерам семейства MSIE
    <IfModule mod_setenvif.c>
    BrowserMatch "MSIE" force-no-vary
    BrowserMatch "Mozilla/4.[0-9]{2}" force-no-vary
    </IfModule>
    Модератор Юрий

    (@yube)

    1. Захожу Записи-Добавить новую.
    2. Вставляю текст.
    3. Жму предпросмотр.

    И где тут «опубликовать»?

    постоянно мигает облако и слово сохранение.

    Что в консоли браузера, ошибки есть? (F12 → console)

    И посмотрите в админке Инструменты → Здоровье сайта. Особое внимание на REST API.

    Это у хостера настройки:
    https://yadi.sk/d/HhAYVOaw-7WUtw
    Не в курсе как прикрепить рисунки тут…

    • Ответ изменён 1 неделя, 6 дн. назад пользователем  legal2019.

    использовать хостинги картинок и
    <img src="">

    Юрий (@yube)

    Состояние здоровья сайта (75%):
    4 рекомендуемых улучшения
    Рекомендуется удалить неактивные плагины (Безопасность)
    Рекомендуется удалить неактивные темы (Безопасность)
    Рекомендуется обновить PHP (Производительность)

    PHP — язык программирования, на основе которого создан WordPress. Новые версии PHP и быстрее и безопаснее, поэтому обновление будет иметь положительный эффект для производительности сайта.
    Одно или несколько рекомендуемых расширений отсутствуют (Производительность)
    Расширения PHP выполняют многие задачи на сервере для обеспечения работы вашего сайта. Обычно любые изменения в них производятся системным администратором сервера.

    Команда хостинга WordPress поддерживает список расширений требуемых и рекомендуемых в этом руководстве (откроется в новой вкладке).

    Внимание! Рекомендуемое расширение bcmath не установлено или отключено.
    Внимание! Рекомендуемое расширение exif не установлено или отключено.
    Внимание! Рекомендуемое расширение imagick не установлено или отключено.

    ****
    Я так понимаю, если:
    1. …удалить неактивные плагины;
    2. …удалить неактивные темы;
    3. …обновить PHP;
    4. …вкл. расширения bcmath + exif + imagick,
    то вместо 75% будет 100%. Или не совсем так?
    ****
    ****
    импорт из «здоровье сайта»
    ****

    
    ### wp-core ###
    
    version: 5.2.3
    site_language: ru_RU
    user_language: ru_RU
    permalink: /%category%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/домен/сайт.ru/docs
    wordpress_size: 66,08 MB (69286836 bytes)
    uploads_path: /home/домен/сайт.ru/docs/img
    uploads_size: 6,70 MB (7025400 bytes)
    themes_path: /home/домен/сайт.ru/docs/wp-content/themes
    themes_size: 22,58 MB (23674293 bytes)
    plugins_path: /home/домен/сайт.ru/docs/wp-content/plugins
    plugins_size: 5,65 MB (5921008 bytes)
    database_size: 10,50 MB (11010048 bytes)
    total_size: 111,50 MB (116917585 bytes)
    
    ### wp-active-theme ###
    
    name: undefined
    version: undefined
    author: Аноним
    author_website: (undefined)
    parent_theme: none
    theme_features: post-thumbnails, menus
    theme_path: /home/домен/сайт.ru/docs/wp-content/themes/сайт
    
    ### wp-themes (5) ###
    
    Dev Menu: author: Аноним, version: (undefined)
    Twenty Fifteen: version: 2.5, author: Команда WordPress
    Twenty Nineteen: version: 1.4, author: Команда WordPress
    Twenty Seventeen: version: 2.2, author: Команда WordPress
    Twenty Sixteen: version: 2.0, author: Команда WordPress
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.6.0
    
    ### wp-plugins-active (5) ###
    
    Akismet Anti-Spam: version: 4.1.2, author: Automattic
    Contact Form 7: version: 5.1.4, author: Takayuki Miyoshi
    Cyr-To-Lat: version: 4.2.3, author: Sergey Biryukov, Mikhail Kobzarev, Igor Gergel
    Google XML Sitemaps: version: 4.1.0, author: Arne Brachhold
    WP Realtime Sitemap: version: 1.5.7, author: Daniel Tweedy
    
    ### wp-plugins-inactive (6) ###
    
    Easy HTML Sitemap: version: 1.4.4, author: a.ankit
    Health Check & Troubleshooting: version: 1.4.0, author: The WordPress.org community
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg
    P3 (Plugin Performance Profiler): version: 1.5.3.9, author: GoDaddy.com
    Query Monitor: version: 3.3.7, author: John Blackbourn
    RusToLat: version: 0.3, author: Anton Skorobogatov <skorobogatov@gmail.com>
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Не доступно
    imagemagick_version: Не доступно
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.0-133-generic x86_64
    httpd_software: Apache/2.4.27 (Ubuntu) PHP/7.2.17 mod_fcgid/2.3.9 mod_perl/2.0.9 Perl/v5.22.1
    php_version: 7.2.17 64bit
    php_sapi: apache2handler
    max_input_variables: 10000
    time_limit: 60
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 64M
    curl_version: 7.47.0 OpenSSL/1.0.2g
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.41-84.1
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/домен/сайт.ru/docs/wp-content
    WP_PLUGIN_DIR: /home/домен/сайт.ru/docs/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    Модератор Yui

    (@fierevere)

    ゆい にゃん子

    то вместо 75% будет 100%. Или не совсем так?

    не нужно гнаться за попугаями.

    на первые два пункта внимания обращать вообще не нужно

    картинка № 1:

    картинка № 2:

    Извиняюсь за спам (если что) первый раз пробую запостить картинку по рекомендации от tuxfighter (@tuxfighter).

    P.S.»Жаль что перед отправкой нет возможности предпросмотр сделать»

    … а как удалить ошибочно опубликованное сообщение на этом форуме?

    • Ответ изменён 1 неделя, 6 дн. назад пользователем  legal2019. Причина: ошибочно опубликовал
    • Ответ изменён 1 неделя, 6 дн. назад пользователем  legal2019.

    tuxfighter (@tuxfighter),
    я так понимаю, что фото лучше так публиковать тут:
    nic-php1
    Чтобы было удобнее просмотреть его в нормальном виде. За спам ещё раз извиняюсь..

    А теперь по делу:
    Здоровье сайта показывает:
    а) Рекомендуется обновить PHP
    б) Версия PHP 7.2.17 (Поддерживает 64-битные значения)

    Тут указано, что PHP 7.0 или выше настоятельно рекомендуется, но WordPress будет работать, с более низкой производительностью, на PHP5.6, а также. По этой причине, PHP версии меньше, чем 7не рекомендуется. Смотрите WordPress и PHP7 для получения дополнительной информации.

    Из этого я делаю вывод о том, что мне не нужно обновлять. Или я не прав? А если нужно обновлять, то как и где?
    Заранее СПС.

    Вот выложил видео проблемы… Кто, что скажет или сможет пояснить почему такое происходит?
    https://youtu.be/ngam5Crcrwo

Просмотр 15 ответов — с 1 по 15 (всего 18)