Поддержка Проблемы и решения при включении ЧПУ возвращает 404

  • Решено cuoresan

    (@cuoresan)


    Доброе время суток, такая проблема, делаю мультиязычный шаблон, плагин WPGlobus, сам плагин требует включение ЧПУ, когда использую «простые» ссылки все работает, но не отрабатывает сам плагин, но когда включаю допустим «название записи» при переходе через меню, страницы и категории возвращают 404, в чем может быть проблема ? в .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

Просмотр 8 ответов — с 1 по 8 (всего 8)
  • если добавить в начало произвольной ссылки ЧПУ index.php/, все работает, как пофиксить ?

    Модератор Denis Yanchevskiy

    (@denisco)

    WordPress-разработчик, wpcute.ru

    Доброе.

    А если заменить в .htaccess на этот код, что-то меняется?

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    ничего не изменилось, уже весь день копаю интернет и не могу найти решение

    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    страницы и категории возвращают 404, в чем может быть проблема ?

    Не установлен модуль mod_rewrite, либо в настройках Apache указана директива AllowOverride None (она может быть выставлена как для сервера в целом, так и для конкретного сайта, нужно проверить все места).

    mod_rewrite включен, а вот на счет AllowOverride надо уточнять у сис админа… а может еще быть что выключена FollowSymLinks и поэтому не работает ?

    Модератор Yui

    (@fierevere)

    ゆい

    выключена FollowSymLinks и поэтому не работает

    нет
    это не должно влиять на работоспособность wordpress и чпу

    ps: какой у вас хостинг ? пробовали ли обращаться в техподдержку хостинга с данным вопросом?

    пробовал, сказали все должно работать, ищите ошибку у себя

    все таки оказалось что причина на хосте AllowOverride None было, спасибо за советы

Просмотр 8 ответов — с 1 по 8 (всего 8)
  • Тема «при включении ЧПУ возвращает 404» закрыта для новых ответов.