• При миграции / клонировании сайта на новый домен в новую папку того же хоста и правильном выполнении всех процедур согласно инструкциям Хабра http://habrahabr.ru/post/246659/
    Проблема: Сайт http://us-patent.ru/ хостинг hostmonster,
    не принимает пароль ни одного юзера вообще.
    Ни админский, ни пользовательские.
    Юзвери в базе данных есть, ок.
    Пробую делать нового юзера — чтоб потом в базе дать ему админские права к примеру — отправляет письмо с подтверждением и паролем, ок.
    Пытаюсь зайти с ними — не принимает. Попытки восстановления пароля — отправляет письмо, по ссылке — белый экран
    В wp-config.php поставил
    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, true);
    в итоге: Видит кучу багов на главной, с этим еще будем разбираться, но
    основное —
    http://us-patent.ru/wp-login.php
    Любую пару логин-пароль он воспринимает как неверную.
    Сообщение дебаггера
    Notice: Undefined variable: control_ops in /home3/solcityu/public_html/uspatento/wp-content/themes/theme1929/includes/widgets/my-social-widget.php on line 7

    Notice: Функция wp_deregister_script вызвана неправильно. Не отменяйте регистрацию скрипта jquery в панели управления. Чтобы сделать это только на внешней части сайта, используйте действие wp_enqueue_scripts. Дополнительную информацию можно найти на странице «Отладка в WordPress». (Это сообщение было добавлено в версии 3.6.) in /home3/solcityu/public_html/uspatento/wp-includes/functions.php on line 3560

Просмотр 5 ответов — с 1 по 5 (всего 5)
  • Модератор Юрій

    (@yube)

    Для начала избавьтесь от BOM.

    Затем выполните пункты 3-6 инструкции.

    Автор alef007

    (@alef007)

    Уважаемый Юрий, приветствую. Благодаря Вам — проблема частично решилась:
    Действительно, BOM содержался в wp-config.php
    После очистки этого файла — по крайней мере, движок принял пароль.
    НО: После приема пароля он переадресует на http://us-patent.ru/wp-admin/ — и чисто белый экран. В исходном коде белой страницы — <!— SHTML Wrapper — 500 Server Error —>
    Тем не менее, при входе на сайт система меня опознает, и отображает «как бы админский доступ» с черной полосой и админ навигацией наверху.
    Однако, при попытке войти в консоль и ли редактировать главную страницу — идет переход на wp-admin/….. и вновь белый экран с той же ошибкой (видна в коде страницы)

    Ну то есть при попытке входа — авторизация происходит, но доступа в админку по прежнему в действительности нет.

    Автор alef007

    (@alef007)

    Отключать плагины из админ панели невозможно, соотв. п.п. 3-6 инструкции выполнить тоже эээ … Отключение плагинов методом переименований папок на сервере эффекта не дало.

    Модератор Юрій

    (@yube)

    и чисто белый экран.

    Нужно смотреть логи ошибок сервера/php.
    FAQ Отображается только белый экран

    Автор alef007

    (@alef007)

    Спасибо… В общем, я пошел по жестокому пути — начиная с нулевой установки вордпресса, заливки темы, дампа базы и и т.д. — в итоге все работает. Но Ваш совет про BOM я не забуду))) сердечно благодарен))

Просмотр 5 ответов — с 1 по 5 (всего 5)
  • Тема «Проблема при миграции сайта — слетел пароль, нид хелп» закрыта для новых ответов.