Поддержка Разное Проблема работы с таксономиями

  • Добрый день. У меня появились две проблемы при работе с таксономиями, просьба помочь решить их. Проблемы расписаны ниже.Спасибо.

    Создан постайп:
    «one_type»
    Созданы таксономии:
    «one_tax»,»two_tax»,»three_tax»
    В каждой таксономии созданы категории:
    «one_cat»,»two_cat»,»three_cat»

    Проблема №1: У меня создана страница «Каталог» с ссылкой http://www.site/one_type — почему-то у меня используется шаблон arhive а не установленный шаблон для данной страницы.
    Проблема №2: При переходе на страницу таксономии http://www.site/one_tax — у меня выдает ошибку 404. При переходе по ссылке http://www.site/one_type/one_tax -так же ошибка 404. При всем этом у меня создан файл taxonomy-one_tax.php но он почему-то срабатывает не для страницы таксономии, а для страницы категории таксономии тоесть к примеру one_cat.

    Просьба помочь в решении данный проблем, несколько дней уже бьюсь в стену, не могу их решить. Большое спасибо.

Просмотр 3 ответов — с 1 по 3 (всего 3)
  • Модератор SeVlad

    (@sevlad)

    wp.me/3YHjQ

    Прежде всего после создания кастомных типов и таксономий стоит пересохранить настройки ЧПУ.

    Для второй проблемы создавайте новый топик См правила форума, п2) указав схему ЧПУ.

    Пересохранял линки в настройках не один раз. Не помогло.

    Модератор SeVlad

    (@sevlad)

    wp.me/3YHjQ

    Ок.

    почему-то у меня используется шаблон arhive а не установленный шаблон для данной страницы.

    Для страницы? Это же у Вас типа поста. Для него (для архива кастомного типа) шаблон создан? Как?

Просмотр 3 ответов — с 1 по 3 (всего 3)
  • Тема «Проблема работы с таксономиями» закрыта для новых ответов.