Поддержка Проблемы и решения Проблема с автообновлением ВП

  • Решено sergeyka2003

    (@sergeyka2003)


    Добрый день!

    Подскажите, пожалуйста, почему у меня старый ВП просит версию ПХП для возможности обновления, но её же и не видит сам???

    1. http://zagad.alexlapin.tmweb.ru/test.php
    2. http://prntscr.com/pki09f — ошибка из админки

    Что нужно сделать, чтобы получилось авто-обновиться?)
    Спасибо.

Просмотр 6 ответов — с 1 по 6 (всего 6)
  • Модератор Yui

    (@fierevere)

    ゆい

    test.php у вас на том же сайте размещен что и WP, который вы пытаетесь обновить?
    На вашем тестовом сайте похоже другие настройки, чем на основном.

    Что за версия WP? По виду скриншота что-то ниже версии 4.0

    Можете обновить вручную, https://ru.wordpress.org/download/releases/
    архивы тут, закачиваете и заменяете /wp-admin/ , /wp-includes/ и .php файлы в корне сайта (wp-config.php в архиве нет, его не трогаете)

    возможно сначала лучше обновить на версию 4.9
    https://ru.wordpress.org/wordpress-4.9.12-ru_RU.zip

    Похоже версия 3.5
    Да, это в корне сайта тест.пхп
    Не хочется что-то руками ковыряться)) если можно разобраться… или не вариант?

    Блин, сорри, сам дурак)))) Разобрался)

    Модератор Yui

    (@fierevere)

    ゆい

    т.е. вы сначала сделали скриншот админки,
    потом увеличили версию PHP на хостинге?

    У вас сайт сейчас не работает, т.к. PHP 7 не поддерживает расширение mysql, а старая версия WP похоже еще не умеет mysqli

    похоже у вас без вариантов, но ручное обновление не так страшно,
    всего-то заменить 2 папки и пачку файлов в корне сайта.

    Про бэкап не забудьте! Никакой гарантии нет, что после обновления сайт с обвязкой старых тем и плагинов не посыпется и вообще будет работать.

    Также найдите где у вас журнал ошибок PHP, если что-то посыпется из плагинов, то указание на проблему искать надо будет там.

    Модератор Yui

    (@fierevere)

    ゆい

    5.6.40 PHP вижу у вас, как вариант вы можете пока использовать ее, временно, для решения проблем с обновлением и после обновления.

    Всё банальнее, оказалось, что я криворукий))
    Обновляю версию пхп на одном сайте, а проверяю на другом)
    Сделал клон и чуть запутался) Посмотрел внимательнее и оказалось что проблем-то и нет)

Просмотр 6 ответов — с 1 по 6 (всего 6)