Поддержка Плагины Проблема с плагином CKEditor после обновления WordPress 4.0

  • Здравствуйте. После обновления WordPress до версии 4.0, плагин CKEditor перестал работать. При добавлении записи/страницы кнопок для редактирования нет, текст страницы виден только когда выделяешь. Отключаю плагин, стандартные кнопки wordpress появляются. Подскажите, в чем может быть проблема? Спасибо.

Просмотр 6 ответов — с 1 по 6 (всего 6)
  • Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    На англоязычном форуме тоже сообщают о несовместимости.

    Попробуйте добавить в functions.php активной темы фрагменты, которые там предлагаются (первый, второй).

    Благодарю за ответ! Действительно, проблема у людей та же. А не подскажите, куда нужно вставлять код? Вот код моей темы (mantra):

    <?php
    /*
     * Functions file
     * Includes all necesary files
     * PLEASE DO NOT EDIT THIS FILE IN ANY WAY
     *
     * @package mantra
     */
    
    // Variable for theme version
    define ("MANTRA_VERSION","2.3.4");
    
    require_once(dirname(__FILE__) . "/admin/main.php"); // Load necessary admin files
    
    //Loading include fiels
    require_once(dirname(__FILE__) . "/includes/theme-setup.php"); //Setup and init theme
    require_once(dirname(__FILE__) . "/includes/theme-styles.php"); //Register and enqeue css styles and scripts
    require_once(dirname(__FILE__) . "/includes/theme-loop.php"); //Loop related fiels
    require_once(dirname(__FILE__) . "/includes/theme-seo.php"); //SEO related fiels
    require_once(dirname(__FILE__) . "/includes/theme-frontpage.php"); //Frontpage generation
    require_once(dirname(__FILE__) . "/includes/theme-comments.php"); //Theme comment functions
    require_once(dirname(__FILE__) . "/includes/theme-shortcodes.php"); //Theme shortcodes
    require_once(dirname(__FILE__) . "/includes/theme-functions.php"); //Theme misc functions
    require_once(dirname(__FILE__) . "/includes/theme-hooks.php"); //Theme hooks
    
    ?>
    Модератор Sergey Biryukov

    (@sergeybiryukov)

    Live and Learn

    Можно перед закрывающим тегом ?> в конце.

    Более правильный вариант (если других изменений в теме не было) — создать дочернюю тему и добавить код в неё.

    Вставил код по первой ссылке так как Вы подсказали. Теперь все работает. Спасибо Вам большое!!!

    Все отлично, вставила код в функции темы и все заработало , как надо! Очень благодарна за подсказку.

    После обновления плагина CKEditor, вставлять код уже не нужно.

Просмотр 6 ответов — с 1 по 6 (всего 6)
  • Тема «Проблема с плагином CKEditor после обновления WordPress 4.0» закрыта для новых ответов.