Поддержка Проблемы и решения Проблема с атрибутом alt для картинок

  • Подскажите пожалуйста: в медиафайлы/библиотека/параметры/ прописываю атрибут alt, а на странице отображается в атрибуте вместо этого либо тег заголовка, либо Title файла.
    Возможно из-за использования плагина Widgetkit.
    Пробма присуща всем страницам сайта.

    • Тема изменена 1 год, 7 месяцев назад пользователем pavlentiy.
    • Тема изменена 1 год, 7 месяцев назад пользователем pavlentiy.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 5 ответов — с 1 по 5 (всего 5)
  • А в изображениях внутри записи прописывать alt не пробовали?

    Это как-бы вариант. Но учитывая количество медиафайлов около 200 и их рост в дальнейшем, не лучший выход.

    Оу, а я написал и подумал, я не спец, но разве физически html страница на диске присутствует. Вроде же в Вордпресс «на лету» формируется.

    Модератор SeVlad

    (@sevlad)

    wp.me/3YHjQ

    но разве физически html страница на диске присутствует. Вроде же в Вордпресс «на лету» формируется.

    И как это связано с рекомендация прописывать alt в контенте (в html-коде в итоге)?
    Конечно же «на лету», но берёт то, что прописано в htnl-коде контента (если Вы про картинки в контенте говорите).

    Но учитывая количество медиафайлов около 200

    На час работу макс. (а если есть доступная логика и знание регулярок, то возможно и гораздо меньше).

    и их рост в дальнейшем,

    Если ДО вставки альты будут прописаны, то они ставятся.

    Спасибо, ключевая фраза была: если картинки в контенте.
    Оказалось, что не в контенте.
    Вопрос возник из-за незнания как работает Widgetkit.

Просмотр 5 ответов — с 1 по 5 (всего 5)
  • Тема «Проблема с атрибутом alt для картинок» закрыта для новых ответов.