Поддержка Проблемы и решения Проблемы админпанели + не работает редактор

  • Предыстория: решил применить cdn, а именно cloudflare, спустя часов 15 обновил в админке страницу с черновиком, появляется надпись «Произошла непредвиденная ошибка.» «Попытка восстановления. Скопировать текст записи. Скопировать текст ошибки.».

    При копировании ошибки пишет, что с плагином Гутенберг проблема:

    TypeError: Cannot read properties of undefined (reading 'page')
        at /wp-content/plugins/gutenberg/build/edit-post/index.min.js?ver=fc239f2ded11f756f541:17:7937
        at /wp-content/plugins/gutenberg/build/data/index.min.js?ver=d9984093176a80497056:1:13009
        at /wp-content/plugins/gutenberg/build/redux-routine/index.min.js?ver=77304ecb13ce81b5a0cc:1:8687
        at /wp-content/plugins/gutenberg/build/data/index.min.js?ver=d9984093176a80497056:1:8611
        at Object.dispatch (/wp-content/plugins/gutenberg/build/data/index.min.js?ver=d9984093176a80497056:1:9685)
        at Object.initializeMetaBoxes (/wp-content/plugins/gutenberg/build/data/index.min.js?ver=d9984093176a80497056:1:13714)
        at /wp-content/plugins/gutenberg/build/edit-post/index.min.js?ver=fc239f2ded11f756f541:38:10659
        at jr (/wp-content/plugins/gutenberg/build/vendors/react-dom.min.js?ver=6.0:1:83481)
        at unstable_runWithPriority (/wp-content/plugins/gutenberg/build/vendors/react.min.js?ver=6.0:1:7430)
        at xn (/wp-content/plugins/gutenberg/build/vendors/react-dom.min.js?ver=6.0:1:29947)

    После выключения плагина:

    TypeError: Cannot read properties of undefined (reading 'page')
        at /wp-includes/js/dist/edit-post.min.js?ver=0066e2a76eff88129280c12c9a52b6b4:7:28532
        at /wp-includes/js/dist/data.min.js?ver=38ad563aa39c8f314fe6f6e430d81a69:2:10446
        at /wp-includes/js/dist/redux-routine.min.js?ver=5156478c032ea85a2bbdceeb7a43b0c1:2:8811
        at /wp-includes/js/dist/data.min.js?ver=38ad563aa39c8f314fe6f6e430d81a69:2:9297
        at Object.dispatch (/wp-includes/js/dist/data.min.js?ver=38ad563aa39c8f314fe6f6e430d81a69:2:10389)
        at Object.initializeMetaBoxes (/wp-includes/js/dist/data.min.js?ver=38ad563aa39c8f314fe6f6e430d81a69:2:14413)
        at /wp-includes/js/dist/edit-post.min.js?ver=0066e2a76eff88129280c12c9a52b6b4:7:86035
        at $r (/wp-includes/js/dist/vendor/react-dom.min.js?ver=17.0.1:9:83333)
        at unstable_runWithPriority (/wp-includes/js/dist/vendor/react.min.js?ver=17.0.1:9:7431)
        at xn (/wp-includes/js/dist/vendor/react-dom.min.js?ver=17.0.1:9:29950)

    Восстановление резервной копии не помогает (если вообще от этого есть смысл).
    Переустановка скрипта в админке не помогла, замена файлов с «ошибкой» так же не помогает.
    Так же в самой админке не работает меню, при наведении не выпадают списки (и всё меню стало серым), у входа в админку пропало ксс*.

    *скриншот входа в админку: https://i.postimg.cc/cCYm7D2t/chrome-u-XKHTir-S1-X.png

Просмотр 3 ответов — с 1 по 3 (всего 3)
  • callmert, привет.

    Предыстория: решил применить cdn

    Сразу вопрос: зачем? Какую задачу хотите решить этим действием?

    Касательно проблемы, думаю, что вы не до конца настроили на стороне CF свой сайт, http/https и пр. Советую посмотреть настройки блока «Encryption modes»: off, flexible, full, full (strict).

    Сразу вопрос: зачем? Какую задачу хотите решить этим действием?

    Я был уверен, что сайт будет грузиться чуть быстрее (как бы это смешно, наверное, не звучало).

    не до конца настроили на стороне CF свой сайт

    Я в итоге удалил сайт полностью из клаудфлера, почистил куки и все заработало. Я для себя понял, что туда, где не разбираюсь лучше не лезть.

    В итоге нужно было следовать мануалу в интернете, тогда бы не было проблем.

    m0ze, благодарю за помощь)

    callmert,

    Я был уверен, что сайт будет грузиться чуть быстрее (как бы это смешно, наверное, не звучало).

    Вообще, вы не так далеки от истины, просто есть ряд нюансов, кторые нужно знать при настройке сайта для работы с CF. В вашем случае, как я уже писал ранее, наиболее вероятен вариант с недостаточной настройкой «Encryption modes».

    m0ze, благодарю за помощь)

    На здоровье 🙂

Просмотр 3 ответов — с 1 по 3 (всего 3)