Поддержка Разное Проблемы в библиотеках JS 3.5.1 в WP 5.6.2

  • JQ библиотека не подключается на планшетах и мобильных устройствах. Дело не в её версии уже правил разные версии и вашу последнюю предыдущую версию 1.12.4 и версию 2.2.4. А в том, что она не подключается. При чем если смотреть из браузера путем адаптации, всё подключается. Но если зайти с планшета или телефона, то из-за того что библиотека не подключается, все скрипты остальные включая других разработчиков не работают и не из-за того что они старые или ещё что-то, ведь версия ПК работает. Либо какой-то скрипт увы забыли добавить, который должен подключатся в на мобильных устройствах и планшетах. Даже google recaptcha и прочие сторонние сервисы не работают из-за отсутствия подключение JQ библиотеки. Почему и где ошибка я пытался найти, пытался всяко разно по-своему и свои загружать JS библиотеки, а также ваши плагины для использования разных версий, тестирование. Не работает и этот баг не даже не знаю исчезнет ли в версии 5.7, и сколько её ждать. Что делать ? Я не могу откатить WP на более старую установку, так как я её взял свежую с сайта для создание нового сайта. Что делать, ждать WP 5.7 и крестить пальцы, что всё будет подключатся и работать ?

    • Тема изменена 7 месяцев, 3 недели назад пользователем seovmig.

    Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Просмотр 9 ответов — с 16 по 24 (всего 24)
  • wp-embed.js от jQuery не зависит, поэтому может подключаться и до, и после.

    Пробовал на самсунге j1 2016 год

    Мобилку я не делал ещё, там будет другой дизайн минимум скриптов. Но судя по «Браузер: Mozilla/5.0 (Android 5.1.1; Mobile; rv:87.0) Gecko/87.0 Firefox/87.0» 🙂 Планшеты есть у кого ? Если порядок не важен почему в планшете всё ломает Скрин 2

    Если я вырежу дефолтные скрипты

    add_action( 'wp_print_scripts', 'de_script', 100 );
    function de_script() {
    	wp_dequeue_script( 'jquery' );
    	wp_deregister_script( 'jquery' );
    }
    
    function wpplus_remove_jquery_migrate( $scripts ) { 
        if ( ! is_admin() && isset( $scripts->registered['jquery'] ) ) { 
            $script = $scripts->registered['jquery']; 
            if ( $script->deps ) { 
    			$script->deps = array_diff( $script->deps, array( 'jquery-migrate' ) ); 
            } 
        } 
    } 
    add_action( 'wp_default_scripts', 'wpplus_remove_jquery_migrate' );

    А потом вставлю их повыше Скрин 3, то на ПК картина становиться такой же как у меня на планшете. По идеи же роли это не должно играть. Может быть собака здесь зарыта, на планшете происходит типа того же и по сути они не работают ? Ещё как скриншоты вставить более проще к вам, а то на сайт к себе вставляю, а модератор так высылает, нужен сайт какой-то или это только модераторы могут ?

    Может дело типа в обработки PHP исходных данных. WP написало, что они работают над поддержкой PHP 8.0, может происходит некая поздняя загрузка скрипта на планшете после совершение загрузки остальных данных, то это бы объяснило бы поведение не рабочих скриптов на планшете. Потому что ставя версию 1.12.4, картина та же самая, что наталкивает на мысль именно тут где-то собака зарыта. Библиотека подгружается в код позднее, чем следовало, что вызвало такое, особенно WP писали работали над оптимизацией работы и кода. А это значит есть вероятность именно этого. Или нет, меня не туда заносит ?

    Как-то это можно проверить ?) не поздно ли она грузиться. У меня такое было, когда я этот файл случайно оптимизировал путем асинхронной загрузки. может движок тоже асинхронно грузит и не везде это работает, ну или типа того.

    Ради эксперимента, мой сайт https://seovmig.ru WP 5.5.3 единственное заскриптованное, это отложенная загрузка видео, ну можно кнопку для теста добавить. Всё везде идеально работает у меня на устройствах. Обновляем до версии WP 5.6.2 и смотрим. Отложенная загрузка прекрасно работает на JQ v.3.5.1 проверенно. Если на планшете проблемы. То скорее всего проблема в движке WP и на уровне PHP поддержки. А мы ищем не там.

    • Ответ изменён 7 месяцев, 3 недели назад пользователем seovmig.

    Хотя че я туплю. Копирую WP 5.5.3 и ставлю на неё дизайн. А остальное пусть, со временем сделают и исправят)) Спасибо ребята. Чет мне это в голову сразу не пришло))

    Планшеты есть у кого ?

    Преимущественно антикварные 🙂 Anroid 6 Crome 87

    screenshot

    Ещё как скриншоты вставить более проще к вам,

    На любой image-хостинг, в т.ч. и свой сайт, а сюда ссылку.
    Я заливаю на https://imgur.com/ и вставляю картинку как <img src=....

    Всё таки проблема оказалась в плагине elementor. Откатил её аж до версии 3.0.5 Тогда всё заработало. Я так не понял в чем проблема и почему при деактивированом плагине, это проблема оставалась. Ой дай бог я не до живу до того момента, когда разработчики таких продуктов будут хуже меня. Ведь я совсем уже не совершенствуюсь в этом направление лет 10, но вижу как сильно идет деградация) и мой низкий уровень, уже стал почти блин средним на рынке (: Надо завязывать с этим АЙТИ 🙂

    Лучше завяжите с использованием всяких мышевозок

Просмотр 9 ответов — с 16 по 24 (всего 24)
  • Тема «Проблемы в библиотеках JS 3.5.1 в WP 5.6.2» закрыта для новых ответов.